Systémy Data Domain s verzemi 7.7.1.0, 7.7.2.0, 7.8.0.0 a 7.8.0.10: Potenciální problém se ztrátou dat při zápisu záloh během cyklu čištění

Summary: Kvůli vzácnému konfliktu časování může v systémech Data Domain (DDR, DDVE a DDVE v cloudu) se systémem DDOS verze 7.7.1.0, 7.7.2.0, 7.8.0.0 a 7.8.0.10 docházet k potenciální ztrátě dat při zápisu záloh během spuštěného čištění. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms


Během cyklu čištění může dojít k nesprávnému smazání dat ze systému. Zálohu již nelze plně přečíst. Pokud k tomuto problému dojde, systém Data Domain Restorer (DDR) může vykazovat jednu nebo více z následujících chyb:
  • Zobrazí se výstraha s informací, že na disku bylo zjištěno poškození:
 
Id      Post Time                  Severity   Class        Object        Message
-----   ------------------------   --------   ----------   -----------   ------------------------------------------------------------------
m0-32   Wed Jun 29 05:19:16 2022   CRITICAL   Filesystem   Tier=Active   EVT-FILESYS-00020: Corruption has been detected in the filesystem.
  • Pokud je dotčený soubor přečten obnovou, replikací, přesunem dat do cloudu nebo cyklem čištění, dojde k neplánovanému restartování systému souborů Data Domain File System (DDFS).


ROZSAH DOPADU
  • Potenciálně dotčené systémy: Systémy DDR, DDVE, DDVE v cloudu se systémem DDOS verze 7.7.1.0, 7.7.2.0, 7.8.0.0, 7.8.0.10. Systémy, na kterých běží jiná verze systému DDOS, nejsou dotčeny.
  • Problém se netýká stávajících záloh zapsaných v dřívější verzi systému DDOS.
  • Problém se netýká záloh vrstvených do cloudu pomocí přesunu dat.
  • Pokud nástroj File Verification ověřil zálohy po skončení posledního čištění a nezobrazila se žádná výstraha „Corruption Detected“, znamená to, že nejsou dotčeny žádné zálohy.
  • Pokud se všechny zálohy úspěšně replikují, znamená to, že systém Data Domain zdroje replikace není dotčen.

Cause

K tomuto problému dochází kvůli vzácnému konfliktu časování.
 

Resolution

Tento problém je vyřešen ve verzích systému DDOS 7.7.1.10, 7.7.2.10, 7.8.0.20 a novějších.  
Vyberte si z aktuálně dostupných verzí na portálu pro stahování a použijte další opravy a vyřešte nejnovější chyby zabezpečení.

Postupujte podle obou částí níže:
(I) Jak zabránit dopadu na nové zálohy
(II) Ověření a náprava integrity dat   

 
(I) Jak zabránit dopadu na nové zálohy

Doporučujeme nainstalovat verzi systému DDOS, která obsahuje opravu tohoto problému.  Pokud je nainstalována verze systému DDOS s danou opravou, není v této části (I) vyžadována žádná další akce.

 
NEBO

Pokud nelze verzi systému DDOS s opravou okamžitě nainstalovat, pokračujte krokem (I):



 
1.  Zakažte plán čištění.
 
# filesys clean set schedule never
Filesystem cleaning is scheduled to run "never".
 
Stop current Clean cycle if running
 
# filesys clean status
Cleaning started at 2022/06/27 12:32:03: phase 4 of 6 (pre-select)
  8.7% complete,   438 GiB free; time: phase  0:00:01, total  0:10:35
 
# filesys clean stop
 
The 'filesys clean stop' command stops the filesystem cleaning.
        Are you sure? (yes|no) [no]: yes
 
ok, proceeding.


 
2.   Pokud je nutné zmírnit problém s kapacitou, před spuštěním čištění zakažte všechen příjem.
 
2a.  Zakažte zálohování/klonování ze zálohovací aplikace.
 
2b.  Zakažte protokoly v systému DataDomain.
# replication disable all
# nfs disable
# cifs disable
# ddboost disable
# vtl disable

 
 
2c.  Spusťte čištění a sledujte proces následujícím způsobem:
 
# filesys clean start
Active tier cleaning started.  Use 'filesys clean watch' to monitor progress.
 
# filesys clean watch
Beginning 'filesys clean' monitoring.  Use Control-C to stop monitoring.
 
Cleaning: phase 1 of 6 (pre-merge)
  100.0% complete,   438 GiB free; time: phase  0:00:42, total  0:00:42-
 
Cleaning: phase 2 of 6 (pre-analysis)
    3.3% complete,   438 GiB free; time: phase  0:00:16, total  0:00:59


 
2d.  Jakmile čištění zahájí 2. fázi (předběžná analýza), znovu povolte plánování záloh a protokoly.
# replication enable all
# nfs enable
# cifs enable
# ddboost enable
# vtl enable

 
POZNÁMKA: Po instalaci verze systému DDOS s opravou nezapomeňte resetovat plán čištění.

Příklad:
# filesys clean set schedule Tue,0600
 

(II) Ověření a náprava integrity dat

Architektura Data Domain zajišťuje ověření všech zapsaných záloh pro účely integrity.  Pokud se ověření některé zálohy nezdaří, zobrazí se výstraha.  Časové razítko souboru „Last Verified“ udává datum a čas posledního ověření souborů.  Pokud je časové razítko „Last Verified“ novější než poslední cyklus čištění A nezobrazuje se žádná výstraha „Corruption Detected“, nejsou dotčeny žádné zálohy.
 
1.  Zkontrolujte, zda se zobrazuje výstraha „Data Integrity“:
Výstraha vypadá takto:
CRITICAL Filesystem Tier=Active EVT-FILESYS-00020: Corruption has been detected in the filesystem.
Check for current alerts with the command below:
# alerts show current



Pokud se výstraha „Data Integrity“ zobrazuje, ihned kontaktujte zákaznickou podporu společnosti Dell Technologies.
 
2.  Pokud se výstraha „Data Alert“ nezobrazuje, zkontrolujte čas dokončení posledního čištění a časové razítko ověření souboru.
 
2a.  Zkontrolujte čas posledního čištění:
# filesys clean status
Cleaning finished at 2022/06/24 16:36:01.
 
 
2b.  Zkontrolujte časové razítko ověření souboru (Verified file timestamp):
Přejděte do režimu SE:
 
# priv set se
        Enter system password: <Enter Serial Num>
# se grep "Last Verified file timestamp:" /ddr/var/support/autosupport
 Last Verified file timestamp: Sat Jun 25 23:00:22 2022  Verify threads running: 1

 
 
  • Pokud je časové razítko ověření souboru (Verified file timestamp) pozdější než datum a čas posledního cyklu čištění, nejsou dotčeny žádné zálohy.  
  • Pokud je časové razítko ověření souboru pozdější než datum a čas posledního cyklu čištění o týden nebo méně, počkejte, až se srovná, a proveďte kontrolu znovu.
POZNÁMKA: Zpoždění časového razítka ověření souboru neznačí přítomnost problému s integritou dat. Pouze to znamená, že soubory zapsané po datu časového razítka ověření souboru zatím nebyly ověřeny.
  • Pokud v případě jakéhokoli systému s dotčenou verzí systému DDOS (nebo systému, který byl nedávno upgradován na opravenou verzi) časové razítko ověření souboru zaostává o více než týden (nebo jej nelze určit), obraťte se na zákaznickou podporu společnosti Dell Technologies a požádejte o pomoc s ověřením dat.
Article Properties
Article Number: 000200905
Article Type: Solution
Last Modified: 11 Dec 2023
Version:  10
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.