PowerEdge: Windows CBS -lokit vievät liikaa levytilaa pakkausvirheiden vuoksi

Summary: %systemroot%\Logs\CBS-kansiossa olevat lokitiedostot on pakattava automaattisesti .cab tiedostoiksi, kun ne saavuttavat tietyn koon. Jos tämä puristus epäonnistuu, tukit voivat kasvaa suuriksi. Lisäksi pakkausapuohjelman vika aiheuttaa muiden suurten lokitiedostojen luomisen, mikä johtaa suureen levytilan kulutukseen. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • Suuret, pakkaamattomat lokitiedostot %systemroot%\Logs\CBS kansio
    • On yksi CBS.log tiedosto sekä yksi tai useampi tiedosto, jonka nimet ovat CbsPersist_datetime.log formaatti.
  • Vähintään yksi suuri .cab %systemroot%\Temp kansio

Cause

Komponenttipohjainen huolto kirjaa sen toiminnan %systemroot%\Logs\CBS kansio. Nämä tiedostot sisältävät merkintöjä, joista on hyötyä Windows Update -ongelmien vianmäärityksessä tai roolien ja ominaisuuksien lisäämisessä, ja ne dokumentoivat, mitä vioittuneita tiedostoja löytyy, jos sellaisia on, ja korvataan järjestelmätiedostojen tarkistuksella (SFC) ja Dism puhdistusprosessit.

Aktiivisen lokin nimi on CBS.log. Kun se saavuttaa tietyn koon, se nimetään uudelleen CbsPersist_datetime.logja pakattu sitten samannimiseen .cab-tiedostoon. Joskus CBS.log tiedoston koko kasvaa kuitenkin nopeasti, eikä integroitu pakkausapuohjelma (makecab.exe) pysty pakkaamaan sitä tämän seurauksena.

Vaikka tämä tilanne on harvinainen, kun se tapahtuu, se aiheuttaa levytilan nopean kulutuksen. Tämä johtuu siitä, että makecab.exe yrittää toistuvasti pakata tiedoston, epäonnistuu siinä ja yrittää pian uudelleen pian sen jälkeen. Joka kerta, kun näin tapahtuu, se luo oman suuren lokitiedoston (.cab-laajennuksella) %systemroot%\Temp kansio.

Resolution

Voit korjata ongelman seuraavasti:

  1. Pysäytä Windows-moduulien asennuspalvelu jollakin seuraavista tavoista:
    • Käynnistä Palvelut-konsoli, napsauta Windows-moduulien asennuspalvelua hiiren kakkospainikkeella ja valitse Pysäytä.
    • Suorita PowerShellissä stop-service TrustedInstaller
    • Suorita komentokehotteessa net stop TrustedInstaller.
  2. Käynnistä Resurssienhallinta ja siirry kohtaan %systemroot%\Logs\CBS.
  3. Poista tai nimeä uudelleen kaikki tämän kansion tiedostot. Älä poista itse kansiota.
  4. Siirry kohtaan %systemroot%\Temp.
  5. Poista tästä kansiosta kaikki tiedostot, joissa on .cab laajennus.
  6. Käynnistä uudelleen palvelin, jota ongelma koskee.

Affected Products

Microsoft Windows Server 2016, Microsoft Windows Server 2019, Microsoft Windows Server 2022, Microsoft Windows 2012 Server, Microsoft Windows 2012 Server R2, OEMR R440, OEMR R450, OEMR R540, OEMR R550, OEMR R5500, OEMR R640, OEMR R6415, OEMR R650 , OEMR R650xs, OEMR R6515, OEMR R6525, OEMR R660, OEMR R660xs, OEMR R6615, OEMR R6625, OEMR R740, OEMR R740xd, OEMR R740xd2, OEMR R7415, OEMR R7425, OEMR R750, OEMR R750xa, OEMR R750xs, OEMR R7515, OEMR R7525, OEMR R760, OEMR R760xa, OEMR R760XD2, OEMR R760xs, OEMR R7615, OEMR R7625, OEMR R840, OEMR R860, OEMR R940, OEMR R940xa, OEMR R960, OEMR XR4510c, OEMR XR4520c, OEMR XR5610, OEMR XR8610t, OEMR XR8620t, PowerEdge R440, PowerEdge R450, PowerEdge R540, PowerEdge R550, PowerEdge R640, PowerEdge R6415, PowerEdge R650, PowerEdge R650xs, PowerEdge R6515, PowerEdge R6525, PowerEdge R660, PowerEdge R660xs, PowerEdge R6615, PowerEdge R6625, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R7415, PowerEdge R7425, PowerEdge R750, PowerEdge R750XA, PowerEdge R750xs, PowerEdge R7515, PowerEdge R7525, PowerEdge R760, PowerEdge R760XA, PowerEdge R760xd2, PowerEdge R760xs, PowerEdge R7615, PowerEdge R7625, PowerEdge R840, PowerEdge R860, PowerEdge R940, PowerEdge R940xa, PowerEdge R960, PowerEdge XR4510c, PowerEdge XR4520c, PowerEdge XR5610, PowerEdge XR8610t, PowerEdge XR8620t ...
Article Properties
Article Number: 000201058
Article Type: Solution
Last Modified: 16 Jul 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.