PowerEdge: Windows CBS -lokit vievät liikaa levytilaa pakkausvirheiden vuoksi
Summary: %systemroot%\Logs\CBS-kansiossa olevat lokitiedostot on pakattava automaattisesti .cab tiedostoiksi, kun ne saavuttavat tietyn koon. Jos tämä puristus epäonnistuu, tukit voivat kasvaa suuriksi. Lisäksi pakkausapuohjelman vika aiheuttaa muiden suurten lokitiedostojen luomisen, mikä johtaa suureen levytilan kulutukseen. ...
Symptoms
- Suuret, pakkaamattomat lokitiedostot
%systemroot%\Logs\CBSkansio- On yksi
CBS.logtiedosto sekä yksi tai useampi tiedosto, jonka nimet ovatCbsPersist_datetime.logformaatti.
- On yksi
- Vähintään yksi suuri .cab
%systemroot%\Tempkansio
Cause
Komponenttipohjainen huolto kirjaa sen toiminnan %systemroot%\Logs\CBS kansio. Nämä tiedostot sisältävät merkintöjä, joista on hyötyä Windows Update -ongelmien vianmäärityksessä tai roolien ja ominaisuuksien lisäämisessä, ja ne dokumentoivat, mitä vioittuneita tiedostoja löytyy, jos sellaisia on, ja korvataan järjestelmätiedostojen tarkistuksella (SFC) ja Dism puhdistusprosessit.
Aktiivisen lokin nimi on CBS.log. Kun se saavuttaa tietyn koon, se nimetään uudelleen CbsPersist_datetime.logja pakattu sitten samannimiseen .cab-tiedostoon. Joskus CBS.log tiedoston koko kasvaa kuitenkin nopeasti, eikä integroitu pakkausapuohjelma (makecab.exe) pysty pakkaamaan sitä tämän seurauksena.
Vaikka tämä tilanne on harvinainen, kun se tapahtuu, se aiheuttaa levytilan nopean kulutuksen. Tämä johtuu siitä, että makecab.exe yrittää toistuvasti pakata tiedoston, epäonnistuu siinä ja yrittää pian uudelleen pian sen jälkeen. Joka kerta, kun näin tapahtuu, se luo oman suuren lokitiedoston (.cab-laajennuksella) %systemroot%\Temp kansio.
Resolution
Voit korjata ongelman seuraavasti:
- Pysäytä Windows-moduulien asennuspalvelu jollakin seuraavista tavoista:
- Käynnistä Palvelut-konsoli, napsauta Windows-moduulien asennuspalvelua hiiren kakkospainikkeella ja valitse Pysäytä.
- Suorita PowerShellissä
stop-service TrustedInstaller - Suorita komentokehotteessa
net stop TrustedInstaller.
- Käynnistä Resurssienhallinta ja siirry kohtaan
%systemroot%\Logs\CBS. - Poista tai nimeä uudelleen kaikki tämän kansion tiedostot. Älä poista itse kansiota.
- Siirry kohtaan
%systemroot%\Temp. - Poista tästä kansiosta kaikki tiedostot, joissa on
.cablaajennus. - Käynnistä uudelleen palvelin, jota ongelma koskee.