PowerEdge: Dzienniki CBS systemu Windows zajmują zbyt dużo miejsca na dysku z powodu błędów kompresji

Summary: Pliki dziennika w folderze %systemroot%\Logs\CBS powinny zostać automatycznie skompresowane do .cab plików, gdy osiągną określony rozmiar. Jeśli kompresja zakończy się niepowodzeniem, dzienniki mogą się powiększyć. Ponadto awaria narzędzia do kompresji powoduje wygenerowanie innych dużych plików dziennika, co powoduje duże zużycie miejsca na dysku. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • Duże, nieskompresowane pliki dziennika w katalogu %systemroot%\Logs\CBS folder
    • Jest jeden CBS.log oraz jeden lub więcej plików o nazwach w polu CbsPersist_datetime.log format.
  • Co najmniej jeden duży plik .cab w katalogu %systemroot%\Temp folder

Cause

Usługa Component-Based Servicing rejestruje swoją aktywność w %systemroot%\Logs\CBS . Pliki te zawierają wpisy przydatne podczas rozwiązywania problemów z usługą Windows Update lub dodawania ról i funkcji, a także dokumentują, jakie uszkodzone pliki, jeśli w ogóle, zostały znalezione i zastąpione przez narzędzie System File Checker (SFC) oraz Dism Procesy oczyszczania.

Aktywny dziennik nosi nazwę CBS.log. Gdy osiągnie określony rozmiar, jego nazwa zostanie zmieniona na CbsPersist_datetime.log, a następnie skompresowany do pliku .cab o tej samej nazwie. Czasami jednak rozmiar pliku CBS.log gwałtownie wzrasta, w wyniku czego zintegrowane narzędzie do kompresji (makecab.exe) nie jest w stanie go skompresować.

Chociaż taka sytuacja zdarza się rzadko, gdy już się zdarzy, powoduje szybkie wykorzystanie miejsca na dysku. Dzieje się tak, ponieważ makecab.exe wielokrotnie próbuje skompresować plik, nie udaje mu się to, a następnie próbuje ponownie wkrótce potem. Za każdym razem, gdy tak się dzieje, generuje duży własny plik dziennika (z rozszerzeniem .cab) w katalogu %systemroot%\Temp .

Resolution

Aby rozwiązać ten problem, wykonaj następujące czynności:

  1. Zatrzymaj usługę Instalator modułów systemu Windows przy użyciu dowolnej z następujących metod:
    • Uruchom konsolę Usługi, kliknij prawym przyciskiem myszy usługę Instalator modułów systemu Windows i wybierz opcję Zatrzymaj.
    • W programie PowerShell uruchom polecenie stop-service TrustedInstaller
    • W wierszu polecenia uruchom polecenie net stop TrustedInstaller.
  2. Uruchom Eksplorator plików i przejdź do %systemroot%\Logs\CBS.
  3. Usuń lub zmień nazwy wszystkich plików w tym folderze. Nie usuwaj samego folderu.
  4. Przejdź do %systemroot%\Temp.
  5. Usuń wszystkie pliki w tym folderze, które mają .cab rozszerzenie.
  6. Uruchom ponownie serwer, którego dotyczy problem.

Affected Products

Microsoft Windows Server 2016, Microsoft Windows Server 2019, Microsoft Windows Server 2022, Microsoft Windows 2012 Server, Microsoft Windows 2012 Server R2, OEMR R440, OEMR R450, OEMR R540, OEMR R550, OEMR R5500, OEMR R640, OEMR R6415, OEMR R650 , OEMR R650xs, OEMR R6515, OEMR R6525, OEMR R660, OEMR R660xs, OEMR R6615, OEMR R6625, OEMR R740, OEMR R740xd, OEMR R740xd2, OEMR R7415, OEMR R7425, OEMR R750, OEMR R750xa, OEMR R750xs, OEMR R7515, OEMR R7525, OEMR R760, OEMR R760xa, OEMR R760XD2, OEMR R760xs, OEMR R7615, OEMR R7625, OEMR R840, OEMR R860, OEMR R940, OEMR R940xa, OEMR R960, OEMR XR4510c, OEMR XR4520c, OEMR XR5610, OEMR XR8610t, OEMR XR8620t, PowerEdge R440, PowerEdge R450, PowerEdge R540, PowerEdge R550, PowerEdge R640, PowerEdge R6415, PowerEdge R650, PowerEdge R650xs, PowerEdge R6515, PowerEdge R6525, PowerEdge R660, PowerEdge R660xs, PowerEdge R6615, PowerEdge R6625, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R7415, PowerEdge R7425, PowerEdge R750, PowerEdge R750XA, PowerEdge R750xs, PowerEdge R7515, PowerEdge R7525, PowerEdge R760, PowerEdge R760XA, PowerEdge R760xd2, PowerEdge R760xs, PowerEdge R7615, PowerEdge R7625, PowerEdge R840, PowerEdge R860, PowerEdge R940, PowerEdge R940xa, PowerEdge R960, PowerEdge XR4510c, PowerEdge XR4520c, PowerEdge XR5610, PowerEdge XR8610t, PowerEdge XR8620t ...
Article Properties
Article Number: 000201058
Article Type: Solution
Last Modified: 16 Jul 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.