PowerEdge: Dzienniki CBS systemu Windows zajmują zbyt dużo miejsca na dysku z powodu błędów kompresji
Summary: Pliki dziennika w folderze %systemroot%\Logs\CBS powinny zostać automatycznie skompresowane do .cab plików, gdy osiągną określony rozmiar. Jeśli kompresja zakończy się niepowodzeniem, dzienniki mogą się powiększyć. Ponadto awaria narzędzia do kompresji powoduje wygenerowanie innych dużych plików dziennika, co powoduje duże zużycie miejsca na dysku. ...
Symptoms
- Duże, nieskompresowane pliki dziennika w katalogu
%systemroot%\Logs\CBSfolder- Jest jeden
CBS.logoraz jeden lub więcej plików o nazwach w poluCbsPersist_datetime.logformat.
- Jest jeden
- Co najmniej jeden duży plik .cab w katalogu
%systemroot%\Tempfolder
Cause
Usługa Component-Based Servicing rejestruje swoją aktywność w %systemroot%\Logs\CBS . Pliki te zawierają wpisy przydatne podczas rozwiązywania problemów z usługą Windows Update lub dodawania ról i funkcji, a także dokumentują, jakie uszkodzone pliki, jeśli w ogóle, zostały znalezione i zastąpione przez narzędzie System File Checker (SFC) oraz Dism Procesy oczyszczania.
Aktywny dziennik nosi nazwę CBS.log. Gdy osiągnie określony rozmiar, jego nazwa zostanie zmieniona na CbsPersist_datetime.log, a następnie skompresowany do pliku .cab o tej samej nazwie. Czasami jednak rozmiar pliku CBS.log gwałtownie wzrasta, w wyniku czego zintegrowane narzędzie do kompresji (makecab.exe) nie jest w stanie go skompresować.
Chociaż taka sytuacja zdarza się rzadko, gdy już się zdarzy, powoduje szybkie wykorzystanie miejsca na dysku. Dzieje się tak, ponieważ makecab.exe wielokrotnie próbuje skompresować plik, nie udaje mu się to, a następnie próbuje ponownie wkrótce potem. Za każdym razem, gdy tak się dzieje, generuje duży własny plik dziennika (z rozszerzeniem .cab) w katalogu %systemroot%\Temp .
Resolution
Aby rozwiązać ten problem, wykonaj następujące czynności:
- Zatrzymaj usługę Instalator modułów systemu Windows przy użyciu dowolnej z następujących metod:
- Uruchom konsolę Usługi, kliknij prawym przyciskiem myszy usługę Instalator modułów systemu Windows i wybierz opcję Zatrzymaj.
- W programie PowerShell uruchom polecenie
stop-service TrustedInstaller - W wierszu polecenia uruchom polecenie
net stop TrustedInstaller.
- Uruchom Eksplorator plików i przejdź do
%systemroot%\Logs\CBS. - Usuń lub zmień nazwy wszystkich plików w tym folderze. Nie usuwaj samego folderu.
- Przejdź do
%systemroot%\Temp. - Usuń wszystkie pliki w tym folderze, które mają
.cabrozszerzenie. - Uruchom ponownie serwer, którego dotyczy problem.