PowerEdge: I registri CBS di Windows occupano troppo spazio su disco a causa di errori di compressione
Summary: I file di registro nella cartella %systemroot%\Logs\CBS devono essere compressi automaticamente in file .cab quando raggiungono una determinata dimensione. Se questa compressione non riesce, i log possono crescere di grandi dimensioni. Inoltre, l'errore dell'utilità di compressione causa la generazione di altri file di registro di grandi dimensioni, con conseguente consumo elevato di spazio su disco. ...
Symptoms
- File di registro di grandi dimensioni e non compressi nella
%systemroot%\Logs\CBScartella- Esiste un singolo
CBS.logpiù uno o più file con nomi nel fileCbsPersist_datetime.logformato.
- Esiste un singolo
- Uno o più file .cab di grandi dimensioni nella
%systemroot%\Tempcartella
Cause
La manutenzione basata su componenti registra la propria attività in %systemroot%\Logs\CBS . Questi file contengono voci utili per la risoluzione dei problemi con Windows Update o per l'aggiunta di ruoli e funzionalità, oltre a documentare quali file danneggiati, se presenti, vengono trovati e sostituiti da Controllo file di sistema (SFC) e Dism processi di pulizia.
Il registro attivo è denominato CBS.log. Quando raggiunge una determinata dimensione, viene rinominato in CbsPersist_datetime.log, quindi compresso in un file .cab con lo stesso nome. A volte, tuttavia, le dimensioni del file CBS.log aumentano rapidamente e l'utilità di compressione integrata (makecab.exe) non è in grado di comprimerlo.
Anche se questa situazione è rara, quando si verifica lo spazio su disco viene consumato rapidamente. Ciò è dovuto al fatto makecab.exe tenta ripetutamente di comprimere il file, non ci riesce e quindi riprova poco dopo. Ogni volta che ciò accade, genera un file di log di grandi dimensioni (con un'estensione .cab) in %systemroot%\Temp .
Resolution
Per risolvere il problema, procedere come segue:
- Arrestare il servizio Windows Modules Installer utilizzando uno dei seguenti metodi:
- Avviare la console Servizi, fare clic con il pulsante destro del mouse sul servizio Windows Modules Installer e selezionare Interrompi.
- In PowerShell, eseguire
stop-service TrustedInstaller - Al prompt dei comandi, eseguire
net stop TrustedInstaller.
- Avviare Esplora file e passare a
%systemroot%\Logs\CBS. - Eliminare o rinominare tutti i file in questa cartella. Non eliminare la cartella stessa.
- Accedere a
%systemroot%\Temp. - Elimina tutti i file in questa cartella che hanno un
.cabestensione. - Riavviare il server interessato.