PowerEdge: I registri CBS di Windows occupano troppo spazio su disco a causa di errori di compressione

Summary: I file di registro nella cartella %systemroot%\Logs\CBS devono essere compressi automaticamente in file .cab quando raggiungono una determinata dimensione. Se questa compressione non riesce, i log possono crescere di grandi dimensioni. Inoltre, l'errore dell'utilità di compressione causa la generazione di altri file di registro di grandi dimensioni, con conseguente consumo elevato di spazio su disco. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • File di registro di grandi dimensioni e non compressi nella %systemroot%\Logs\CBS cartella
    • Esiste un singolo CBS.log più uno o più file con nomi nel file CbsPersist_datetime.log formato.
  • Uno o più file .cab di grandi dimensioni nella %systemroot%\Temp cartella

Cause

La manutenzione basata su componenti registra la propria attività in %systemroot%\Logs\CBS . Questi file contengono voci utili per la risoluzione dei problemi con Windows Update o per l'aggiunta di ruoli e funzionalità, oltre a documentare quali file danneggiati, se presenti, vengono trovati e sostituiti da Controllo file di sistema (SFC) e Dism processi di pulizia.

Il registro attivo è denominato CBS.log. Quando raggiunge una determinata dimensione, viene rinominato in CbsPersist_datetime.log, quindi compresso in un file .cab con lo stesso nome. A volte, tuttavia, le dimensioni del file CBS.log aumentano rapidamente e l'utilità di compressione integrata (makecab.exe) non è in grado di comprimerlo.

Anche se questa situazione è rara, quando si verifica lo spazio su disco viene consumato rapidamente. Ciò è dovuto al fatto makecab.exe tenta ripetutamente di comprimere il file, non ci riesce e quindi riprova poco dopo. Ogni volta che ciò accade, genera un file di log di grandi dimensioni (con un'estensione .cab) in %systemroot%\Temp .

Resolution

Per risolvere il problema, procedere come segue:

  1. Arrestare il servizio Windows Modules Installer utilizzando uno dei seguenti metodi:
    • Avviare la console Servizi, fare clic con il pulsante destro del mouse sul servizio Windows Modules Installer e selezionare Interrompi.
    • In PowerShell, eseguire stop-service TrustedInstaller
    • Al prompt dei comandi, eseguire net stop TrustedInstaller.
  2. Avviare Esplora file e passare a %systemroot%\Logs\CBS.
  3. Eliminare o rinominare tutti i file in questa cartella. Non eliminare la cartella stessa.
  4. Accedere a %systemroot%\Temp.
  5. Elimina tutti i file in questa cartella che hanno un .cab estensione.
  6. Riavviare il server interessato.

Affected Products

Microsoft Windows Server 2016, Microsoft Windows Server 2019, Microsoft Windows Server 2022, Microsoft Windows 2012 Server, Microsoft Windows 2012 Server R2, OEMR R440, OEMR R450, OEMR R540, OEMR R550, OEMR R5500, OEMR R640, OEMR R6415, OEMR R650 , OEMR R650xs, OEMR R6515, OEMR R6525, OEMR R660, OEMR R660xs, OEMR R6615, OEMR R6625, OEMR R740, OEMR R740xd, OEMR R740xd2, OEMR R7415, OEMR R7425, OEMR R750, OEMR R750xa, OEMR R750xs, OEMR R7515, OEMR R7525, OEMR R760, OEMR R760xa, OEMR R760XD2, OEMR R760xs, OEMR R7615, OEMR R7625, OEMR R840, OEMR R860, OEMR R940, OEMR R940xa, OEMR R960, OEMR XR4510c, OEMR XR4520c, OEMR XR5610, OEMR XR8610t, OEMR XR8620t, PowerEdge R440, PowerEdge R450, PowerEdge R540, PowerEdge R550, PowerEdge R640, PowerEdge R6415, PowerEdge R650, PowerEdge R650xs, PowerEdge R6515, PowerEdge R6525, PowerEdge R660, PowerEdge R660xs, PowerEdge R6615, PowerEdge R6625, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R7415, PowerEdge R7425, PowerEdge R750, PowerEdge R750XA, PowerEdge R750xs, PowerEdge R7515, PowerEdge R7525, PowerEdge R760, PowerEdge R760XA, PowerEdge R760xd2, PowerEdge R760xs, PowerEdge R7615, PowerEdge R7625, PowerEdge R840, PowerEdge R860, PowerEdge R940, PowerEdge R940xa, PowerEdge R960, PowerEdge XR4510c, PowerEdge XR4520c, PowerEdge XR5610, PowerEdge XR8610t, PowerEdge XR8620t ...
Article Properties
Article Number: 000201058
Article Type: Solution
Last Modified: 16 Jul 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.