PowerEdge:由于压缩失败,Windows CBS 日志占用过多磁盘空间
Summary: 当 %systemroot%\Logs\CBS 文件夹中的日志文件达到特定大小时,应自动将其压缩为 .cab 文件。如果此压缩失败,日志可能会变大。此外,压缩实用程序的故障会导致生成其他大型日志文件,从而导致大量磁盘空间消耗。
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
- 未压缩的大型日志文件位于
%systemroot%\Logs\CBS文件夹- 有单个
CBS.log文件,加上一个或多个名称在CbsPersist_datetime.log格式。
- 有单个
- 中的一个或多个大型 .cab 文件
%systemroot%\Temp文件夹
Cause
基于组件的服务将其活动记录在 %systemroot%\Logs\CBS 文件夹中。这些文件包含对 Windows Update 问题进行故障处理或添加角色和功能时非常有用的条目,以及它们记录了发现哪些损坏的文件(如果有)并由系统文件检查器 (SFC) 和 Dism 清理过程。
活动日志被命名为 CBS.log。当它达到一定大小时,它被重命名为 CbsPersist_datetime.log,然后压缩成同名的 .cab 文件。但是,有时CBS.log文件的大小会迅速增加,因此集成压缩实用程序 (makecab.exe) 无法对其进行压缩。
虽然这种情况很少见,但一旦发生,就会导致磁盘空间迅速消耗。这是因为makecab.exe反复尝试压缩文件,但未能成功,并在不久后再次尝试压缩。每次发生这种情况时,.cab它都会在 %systemroot%\Temp 文件夹中。
Resolution
要解决该问题,请执行以下步骤:
- 使用以下任一方法停止 Windows 模块安装程序服务:
- 启动服务控制台,右键单击 Windows 模块安装程序服务 ,然后选择停止。
- 在 PowerShell 中,运行
stop-service TrustedInstaller - 在命令提示符下,运行
net stop TrustedInstaller。
- 启动 File Explorer 并浏览至
%systemroot%\Logs\CBS。 - 删除或重命名此文件夹中的所有文件。请勿删除文件夹本身。
- 浏览至
%systemroot%\Temp。 - 删除此文件夹中具有
.cab外延。 - 重新启动受影响的服务器。
Affected Products
Microsoft Windows Server 2016, Microsoft Windows Server 2019, Microsoft Windows Server 2022, Microsoft Windows 2012 Server, Microsoft Windows 2012 Server R2, OEMR R440, OEMR R450, OEMR R540, OEMR R550, OEMR R5500, OEMR R640, OEMR R6415, OEMR R650
, OEMR R650xs, OEMR R6515, OEMR R6525, OEMR R660, OEMR R660xs, OEMR R6615, OEMR R6625, OEMR R740, OEMR R740xd, OEMR R740xd2, OEMR R7415, OEMR R7425, OEMR R750, OEMR R750xa, OEMR R750xs, OEMR R7515, OEMR R7525, OEMR R760, OEMR R760xa, OEMR R760XD2, OEMR R760xs, OEMR R7615, OEMR R7625, OEMR R840, OEMR R860, OEMR R940, OEMR R940xa, OEMR R960, OEMR XR4510c, OEMR XR4520c, OEMR XR5610, OEMR XR8610t, OEMR XR8620t, PowerEdge R440, PowerEdge R450, PowerEdge R540, PowerEdge R550, PowerEdge R640, PowerEdge R6415, PowerEdge R650, PowerEdge R650xs, PowerEdge R6515, PowerEdge R6525, PowerEdge R660, PowerEdge R660xs, PowerEdge R6615, PowerEdge R6625, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R7415, PowerEdge R7425, PowerEdge R750, PowerEdge R750XA, PowerEdge R750xs, PowerEdge R7515, PowerEdge R7525, PowerEdge R760, PowerEdge R760XA, PowerEdge R760xd2, PowerEdge R760xs, PowerEdge R7615, PowerEdge R7625, PowerEdge R840, PowerEdge R860, PowerEdge R940, PowerEdge R940xa, PowerEdge R960, PowerEdge XR4510c, PowerEdge XR4520c, PowerEdge XR5610, PowerEdge XR8610t, PowerEdge XR8620t
...
Article Properties
Article Number: 000201058
Article Type: Solution
Last Modified: 16 Jul 2025
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.