PowerEdge: L'esecuzione delle risorse nel sistema operativo Linux causa un riavvio

Summary: SUSE Linux Enterprise Server per SAP veniva riavviato a intermittenza, una o due volte alla settimana.

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Symptoms

SUSE Linux Enterprise Server per SAP veniva riavviato a intermittenza, una o due volte alla settimana. Si tratta di server cluster a 2 nodi in esecuzione con SAP HANA.
Dai registri del cluster, indicato che il nodo primario secondario veniva riavviato a causa dell'errore monitorato dalle risorse del cluster.

Cause

Esaminati i registri prima del riavvio, i seguenti risultati.


resouces_unavailable 
 

Resolution

L'errore "Resource temporarily unavailable" indica che il sistema operativo sta esaurendo le risorse.
In questo caso, controllare il report SAR prima del riavvio del server.

00:00:01      runq-sz  plist-sz   ldavg-1   ldavg-5  ldavg-15   blocked
16:40:01           20     32595      9.01      9.97      5.46         0
16:50:01           15     32611      1.49      2.81      3.70         0

Ci sono 32.611 processi in esecuzione. Tuttavia, il numero massimo di processi consentiti è:
kernel.pid_max = 32768  (Ottenerlo dal file di registro) env.txt o dal comando del sistema operativo "sysctl -a | grep pid_max"
Quindi questo ha concluso che il server ha raggiunto il massimo dei processi consentiti. Il cliente può verificare con il comando "ps aux" per rivedere se tutti i processi sono necessari o potrebbero essere i processi non interrotti correttamente e continuare a creare nuovi processi.
Risolti i processi non necessari, risolto il problema

Affected Products

SUSE Linux Enterprise Server 12, Red Hat Enterprise Linux Version 7, Red Hat Enterprise Linux Version 8, SUSE Linux Enterprise Server 15

Products

OEMR R240, OEMR R340, OEMR R350, OEMR R360, OEMR R440, OEMR R450, OEMR R540, OEMR R550, OEMR R640, OEMR R650, OEMR R650xs, OEMR R6515, OEMR R6525, OEMR R660, OEMR R660xs, OEMR R6615, OEMR R6625, OEMR R740, OEMR R740xd, OEMR R740xd2, OEMR R7415 , OEMR R750, OEMR R7515, OEMR R7525, OEMR R760, OEMR R760xa, OEMR R760XD2, OEMR R760xs, OEMR R7615, OEMR R7625, OEMR R840, OEMR R860, OEMR R940, OEMR R960, PowerEdge R240, PowerEdge R340, PowerEdge R350, PowerEdge R360, PowerEdge R440, PowerEdge R450, PowerEdge R540, PowerEdge R550, PowerEdge R640, PowerEdge R650, PowerEdge R650xs, PowerEdge R6515, PowerEdge R6525, PowerEdge R660, PowerEdge R660xs, PowerEdge R6615, PowerEdge R6625, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R7415, PowerEdge R7425, PowerEdge R750, PowerEdge R7515, PowerEdge R7525, PowerEdge R760, PowerEdge R760XA, PowerEdge R760xd2, PowerEdge R760xs, PowerEdge R7615, PowerEdge R7625, PowerEdge R840, PowerEdge R860, PowerEdge R940, PowerEdge R960 ...
Article Properties
Article Number: 000201809
Article Type: Solution
Last Modified: 02 Sep 2025
Version:  2
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