Report sulle vulnerabilità di RecoverPoint e RecoverPoint for VMs: Scambio di chiavi SSL o TLS debole rilevato sugli RPA durante la scansione della sicurezza Porta TCP 8082 e 8084
Summary: Il server SSL o TLS supporta scambi di chiavi crittograficamente più deboli di quanto consigliato.
Symptoms
L'esecuzione di uno scanner di vulnerabilità su RecoverPoint (RP) mostra i seguenti messaggi:
Scambio di chiavi SSL/TLS debole rilevato sugli RPA durante la scansione della sicurezza Porta TCP 8082 e 8084
Cause
Gli scambi di chiavi devono fornire almeno 224 bit di sicurezza. Ciò si traduce in una dimensione minima della chiave di 2.048 bit per gli scambi di chiavi Diffie-Hellman e RSA.
Resolution
Soluzione alternativa:
lo script riportato di seguito è applicabile sia a RecoverPoint Classic che a RecoverPoint for VMs.
Utilizzare la procedura riportata di seguito su tutti gli RPA e riavviarli uno alla volta.
"Connection to server failed."
Accedere al menu di installazione dell RPA (admin in RecoverPoint for VMs, boxmgmt in RecoverPoint Classic):
[2] Setup
[8] Advanced options
[4] Run script
Incollare quanto segue e premere Invio:
MzMyYmJjN2I3NDEwMTY2NDk5ODY1MzExNzYzMGQxMWMKdW5saW1pdGVkCm5vdF9yZXN0cmljdGVk
ClRoZSBpZCBvZiB0aGUgc2NyaXB0IGlzOlJQLTM1NjQ4CkNoYW5nZSBESCBrZXlTaXplIHRvIDIw
NDgKQXNzaWYgSGFsCmlmIFtbIGBncmVwIC1jICJESCBrZXlTaXplIDwgMTAyNCIgL3Vzci9rYXNo
eWEvamF2YS9qcmUvbGliL3NlY3VyaXR5L2phdmEuc2VjdXJpdHlgIC1ndCAwIF1dOyB0aGVuCglz
ZWQgLWkgJ3MvREgga2V5U2l6ZSA8IDEwMjQvREgga2V5U2l6ZSA8IDIwNDgvJyAvdXNyL2thc2h5
YS9qYXZhL2pyZS9saWIvc2VjdXJpdHkvamF2YS5zZWN1cml0eQoJc2VydmljZT1gc3lzdGVtY3Rs
IC0tYWxsIHwgZ3JlcCAtaSB0b21jYXQgfCBzZWQgInMvXC5zZXJ2aWNlLiovLyJ8c2VkICJzLy4q
dG9tY2F0L3RvbWNhdC8iYAoJaWYgW1sgJHtzZXJ2aWNlfSA9ICoidG9tY2F0IiogXV07IHRoZW4K
CQlzeXN0ZW1jdGwgcmVzdGFydCAke3NlcnZpY2V9CgllbHNlCgkJcHMgLWVmIHwgZ3JlcCAidG9t
Y2F0LXN0YXJ0IiB8IGdyZXAgLXYgZ3JlcCB8IGF3ayAne3ByaW50ICQyfSd8eGFyZ3Mga2lsbCAt
OQoJZmkKCWVjaG8gIlNjcmlwdCByYW4gc3VjY2Vzc2Z1bGx5IgplbHNlCgllY2hvICJObyBpc3N1
ZXMgZm91bmQuIE5vIENoYW5nZXMgbWFkZSIKZmkK
#
Risoluzione:
Dell Engineering sta esaminando il problema. Non è ancora disponibile una correzione permanente. Contattare il centro di assistenza clienti Dell o il responsabile dell'assistenza per assistenza e fare riferimento a questo ID soluzione.