PowerProtect. Виртуальная машина теряет подключение к сети во время выполнения резервного копирования

Summary: Резервное копирование приводит к тому, что виртуальная машина (ВМ) теряет подключение к сети примерно на одну минуту.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

PowerProtect Data Manager используется для защиты среды vSphere с помощью решения VM Direct Engine. Имеется виртуальная машина (ВМ) с несколькими терабайтными (ТБ) дисками, настроенными для защиты. Во время запланированного окна резервного копирования виртуальная машина периодически теряет подключение к сети в течение примерно одной минуты. Это приводит к истечению времени ожидания некоторых подключений приложений. В журнале сессий резервного копирования не отображается никаких ошибок во время создания моментального снимка:

...
YYYY-MM-DD 19:00:14.890Z TRACE:  [b721339cb9a6e1fa;9cb66c72289daafc] Checking for old snapshots to cleanup ...
YYYY-MM-DD 19:00:14.890Z TRACE:  [b721339cb9a6e1fa;9cb66c72289daafc] No pre-existing snapshots found.
YYYY-MM-DD 19:00:14.890Z TRACE:  [b721339cb9a6e1fa;9cb66c72289daafc] Sending status 'Creating snapshot of virtual machine ...' ...
YYYY-MM-DD 19:00:14.890Z INFO:   [b721339cb9a6e1fa;9cb66c72289daafc] Creating snapshot of virtual machine ...
YYYY-MM-DD 19:00:14.890Z TRACE:  [b721339cb9a6e1fa;9cb66c72289daafc] Sending create snapshot request to Snapshot Manager ...
YYYY-MM-DD 19:00:42.423Z TRACE:  [b721339cb9a6e1fa;9cb66c72289daafc] Sending state of 'Running' (last: state=Queued, progress=0).
YYYY-MM-DD 19:01:12.433Z TRACE:  [b721339cb9a6e1fa;9cb66c72289daafc] Sending state of 'Running' (last: state=Running, progress=0).
YYYY-MM-DD 19:01:14.361Z INFO:   [b721339cb9a6e1fa;9cb66c72289daafc] Create snapshot request succeeded.
YYYY-MM-DD 19:01:14.364Z INFO:   [b721339cb9a6e1fa;9cb66c72289daafc] Found snapshot "snapshot-16906".
...

Потеря подключения к сети также включает прерывание сеанса удаленного рабочего стола и ответа на ping:

ping_drop.png

Cause

Для решения VM Direct Engine требуется моментальный снимок виртуальной машины в начале рабочего процесса резервного копирования. Запрос на создание моментального снимка виртуальной машины выполняется с помощью вызова VMware Simple Object Access Protocol (SOAP) к серверу vCenter. Затем vCenter совместно с сервером ESXi, проводящим хостинг, создает моментальный снимок виртуальной машины.

Файл vmware*log виртуальной машины показывает, что запрос моментального снимка должен был замедлить виртуальную машину в течение 59 022 933 микросекунд, что преобразуется в 59,022933 с.

YYYY-MM-DD 19:01:14.087Z| vcpu-0| I005: CPT: vm was stunned for 59022933 us

Эта ошибка предназначена для создания моментальных снимков VMware vSphere, чтобы записывать любые изменения на диск в памяти. В большинстве случаев оглушение достаточно мало, чтобы не вызывать сбоев сети в среде.  
 

Resolution

Оглушение затронутого механизма защиты виртуальных машин предусмотрено во время создания моментального снимка виртуальной машины.

Временное решение.
Решение PowerProtect Data Manager VMware Protection предлагает решение Transparent Snapshot Data Mover (TSDM), которому не требуется моментальный снимок виртуальной машины для выполнения резервного копирования. Решение TSDM использует фильтр Lightweight Delta (LWD) на уровне хранилища данных для отслеживания различий в отслеживании изменений блоков с момента последнего резервного копирования. Затронутая ВМ может быть защищена с помощью решения TSDM, чтобы предотвратить оглушение во время резервного копирования. В руководстве пользователя PowerProtect Data Manager Virtual Machine «Защита виртуальных машин с помощью Transparent Snapshot Data Mover» представлен обзор механизма защиты.

Additional Information

Если для минимизации времени отключения моментальных снимков виртуальной машины требуются дополнительные рекомендации, можно открыть службу поддержки Broadcom для получения дополнительных отзывов.

Article Properties
Article Number: 000215441
Article Type: Solution
Last Modified: 03 Dec 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.