PowerProtect: Deployment or Upgrading of Reporting Engine to 19.17 Reporting Engine fails
Summary: Deployment or Upgrading of PowerProtect Data Manager Reporting Engine to 19.17 Reporting Engine may fail.
Symptoms
Deploying a new Reporting Engine or upgrading to 19.17.0-10 fails with:
Node configuration failed. Failed to start the report service.
The following errors are found in the /var/log/dellemc/reporting/reporting-service/reporting-service.log:
YYYY-MM-DD HH:MM:SS INFO [PID_IS_UNDEFINED] [main] [c.e.a.common.util.Util.isCertsConfigured(44)] - Is certificates configured false YYYY-MM-DD HH:MM:SS ERROR [PID_IS_UNDEFINED] [main] [c.e.c.s.CoreStartupApplication.init(44)] - Not able to initialize services, missing required certificates.
The Reporting Node has been configured with three Domain Name Server (DNS) entries. The nslookup of the IP address fails on the Reporting Node fails with:
ppdmreportengine:# nslookup 192.168.9.152 nslookup: parse of /etc/resolv.conf failed
Cause
The certificate generation process fails because the Reporting Node is not able to perform a nslookup of the Reporting node IP address. The certification generation requires the Fully Qualified Domain Name (FQDN) that is retrieved from the nslookup output. The nslookup failure is caused due to the nameserver content of the /etc/resolv.conf file. Instead of having separate entries for each nameserver, the secondary and Tertiary DNS entries were merged into one line.
nameserver 192.168.9.100 nameserver 192.168.9.1,192.168.9.2
Resolution
To work around the issue on PowerProtect 19.17.0-10, contact Dell Support for assistance or further questions.