ismo: I certificati SSL in Windows Personal Store scompaiono all'avvio del servizio iSM 5.4.0

Summary: I certificati SSL scompaiono nell'archivio dei certificati personali di Windows Server all'avvio del servizio iDRAC Service Module 5.4.0. Ciò si verifica se il nome host iDRAC è esattamente uguale al nome host impostato in Windows. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

All'avvio del servizio DSM iDRAC Service Module (iSM) in Windows Server, è possibile che un certificato SSL sia inaspettatamente scomparso dall'archivio personale, come mostrato nella console di gestione dei certificati. Il certificato rimosso potrebbe essere stato installato ed essere richiesto da altre applicazioni o servizi di terze parti con possibili errori.

Cause

Questo problema si verifica quando iDRAC è configurato con la stessa stringa del nome host del nome host impostato in Windows. All'avvio del servizio, iSM interroga l'Integrated Dell Remote Access Controller (iDRAC) per ottenere il certificato SSL e crea un certificato web iSM nell'archivio personale da condividere con iDRAC per stabilire un canale di comunicazione sicuro. Una volta arrestato, il servizio iSM rimuove il certificato iDRAC, ma lo copia nuovamente al successivo avvio del servizio. Il problema è che iSM potrebbe eliminare accidentalmente un certificato diverso creato localmente che deve utilizzare il nome host Windows. Questo indipendentemente dal fatto che i nomi di dominio che aggiungono l'iDRAC o i nomi host Windows siano diversi.

Resolution

Dell Engineering risolverà questo problema in una versione futura di iSM.

Nel frattempo, si consiglia di rinominare il nome host iDRAC in qualcosa di leggermente diverso dal nome host Windows. Questa operazione viene eseguita nell'interfaccia utente web di iDRAC, accedendo prima a iDRAC Settings > Connectivity > Network > Common Settings. Modificare il DNS iDRAC Name e cliccare sul pulsante Apply.

Sono interessati solo i certificati SSL presenti nell'archivio personale. Tutti i certificati creati da un'autorità di certificazione e spostati nell'archivio personale non sono interessati.

Affected Products

iDRAC Service Module, iDRAC Service Module 5.x
Article Properties
Article Number: 000232069
Article Type: Solution
Last Modified: 04 Sep 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.