isme: SSL-sertifikater i Windows Personal Store forsvinner ved oppstart av iSM 5.4.0-tjenesten

Summary: SSL-sertifikater forsvinner i det personlige sertifikatlageret på Windows Server når iDRAC Service Module 5.4.0-tjenesten startes. Dette skjer hvis iDRAC-vertsnavnet er nøyaktig det samme som vertsnavnet som er angitt i Windows. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Når tjenesten DSM iDRAC Service Module (iSM) i Windows Server startes, kan det bli lagt merke til at et SSL-sertifikat uventet har forsvunnet fra det personlige lageret som vist i sertifikatadministrasjonskonsollen. Dette fjernede sertifikatet kan ha blitt installert og trengs av andre tredjepartsprogrammer eller -tjenester som kan mislykkes.

Cause

Dette problemet oppstår når iDRAC er konfigurert med nøyaktig samme vertsnavnstreng som vertsnavnet som er angitt i Windows. Ved servicestart spør iSM SSL-sertifikatet til Integrated Dell Remote Access Controller (iDRAC) og oppretter et iSM-websertifikat i det personlige lageret for å dele det med iDRAC for å etablere en sikker kommunikasjonskanal. Når iSM-tjenesten er stoppet, fjernes iDRAC-sertifikatet, men kopieres på nytt ved neste servicestart. Problemet er at iSM ved et uhell kan slette et annet sertifikat opprettet lokalt som må bruke Windows-vertsnavnet. Dette gjelder uavhengig av om domenenavnene som føyes til iDRAC- eller Windows-vertsnavnene, er forskjellige.

Resolution

Dells teknikere vil løse dette problemet i en fremtidig iSM-utgivelse.

I mellomtiden foreslås det å endre navnet på iDRAC-vertsnavnet til noe litt annet enn Windows-vertsnavnet. Dette gjøres i iDRAC-nettgrensesnittet ved først å gå til iDRAC-innstillinger>, tilkobling>, nettverksfellesinnstillinger>. Endre DNS iDRAC-navnet , og klikk på Bruk-knappen.

SSL-sertifikater bare i den personlige butikken påvirkes. Sertifikater som er opprettet av en sertifiseringsinstans og flyttet til det personlige lageret, påvirkes ikke.

Affected Products

iDRAC Service Module, iDRAC Service Module 5.x
Article Properties
Article Number: 000232069
Article Type: Solution
Last Modified: 04 Sep 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.