Cisco MDS : Das Festlegen von Startvariablen schlägt fehl mit der Meldung "Abweichung zwischen tatsächlichem Image-Typ und der Startvariablen (0x4045001E)".

Summary: Kunden, die ein disruptives Upgrade von NX-OS 6.2.23 auf 9.4.2a durchführen.

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Symptoms

Die folgende Syntax zum Festlegen von Startvariablen:
switch(config)#
no boot system
switch(config)#
boot bootflash:<kickstart new_kickstart_image_name>
switch(config)#
boot bootflash:<system new_system_image_name>
switch(config)#
end
switch#
copy running-config startup-config
switch#
reload

Kunde, der den folgenden Befehl auf einem MDS 9148S ausführt:
MDS9148S(config)# boot kickstart bootflash:m9148-s6ek9-kickstart-mz.9.4.2a.bin

Performing image verification and compatibility check, please wait....
Failed to configure bootvar kickstart for sup-1: mismatch between actual image type and boot variable (0x4045001E)

Cause

Falsches Image wird für die Cisco MDS9148s-Plattform verwendet:
Von MDS9148s:
MDS9148s# show version
  kickstart image file is: bootflash:///m9100-s5ek9-kickstart-mz.6.2.23.bin
  kickstart compile time:  3/31/2018 23:00:00 [02/20/2018 18:47:57]
  system image file is:    bootflash:///m9100-s5ek9-mz.6.2.23.bin
  system compile time:     3/31/2018 23:00:00 [02/20/2018 19:58:46]

Beachten Sie, dass die "show version from switch" :-m9100-s5ek9
lautet
. Der Versuch, Startvariablen mit einem Image von einer anderen Plattform festzulegen, schlägt jedoch fehl :
-m9148-s6ek9

Resolution

Sicherstellen, dass für jede Plattform
die richtigen System-/Kickstart-Images verwendet werden Plattform-Images können von für jeden Switchtyp heruntergeladen werden:
https://www.dell.com/support/home/en-ie/product-support/product/connectrix/drivers

Affected Products

Connectrix MDS-9148S
Article Properties
Article Number: 000249589
Article Type: Solution
Last Modified: 12 Mar 2025
Version:  2
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