Cisco MDS : Ustawienie zmiennych rozruchowych kończy się niepowodzeniem z komunikatem "niezgodność między rzeczywistym typem obrazu a zmienną rozruchową (0x4045001E)"

Summary: Klient przeprowadzający zakłócające uaktualnienie z wersji NX-OS 6.2.23 do 9.4.2a .

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Składnia używana do ustawiania zmiennych rozruchowych w następujący sposób:
switch(config)#
no boot system
switch(config)#
boot bootflash:<kickstart new_kickstart_image_name>
switch(config)#
boot bootflash:<system new_system_image_name>
switch(config)#
end
switch#
copy running-config startup-config
switch#
reload

Klient uruchamiający następujące polecenie na urządzeniu MDS 9148S:
MDS9148S(config)# boot kickstart bootflash:m9148-s6ek9-kickstart-mz.9.4.2a.bin

Performing image verification and compatibility check, please wait....
Failed to configure bootvar kickstart for sup-1: mismatch between actual image type and boot variable (0x4045001E)

Cause

Nieprawidłowy obraz używany dla platformy Cisco MDS9148s:
Z MDS9148s:
MDS9148s# show version
  kickstart image file is: bootflash:///m9100-s5ek9-kickstart-mz.6.2.23.bin
  kickstart compile time:  3/31/2018 23:00:00 [02/20/2018 18:47:57]
  system image file is:    bootflash:///m9100-s5ek9-mz.6.2.23.bin
  system compile time:     3/31/2018 23:00:00 [02/20/2018 19:58:46]

Zauważ, że pokaż wersję z przełącznika :
-m9100-s5ek9
Ale próba ustawienia zmiennych rozruchowych z obrazem z innej platformy, co się nie powiedzie :
-m9148-s6ek9

Resolution

Upewnij się, że dla każdej platformy
używane są poprawne obrazy systemu/kickstartu Obrazy platformy, z których można pobrać dla każdego typu przełącznika:
https://www.dell.com/support/home/en-ie/product-support/product/connectrix/drivers

Affected Products

Connectrix MDS-9148S
Article Properties
Article Number: 000249589
Article Type: Solution
Last Modified: 12 Mar 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.