PowerScale : Le pilote audit_flt du processus SMB est à l’état d’arrêt, ce qui entraîne une indisponibilité des données du nœud

Summary: Un problème a été identifié sur le code OneFS 9.7, où le pilote d’audit ne se charge pas correctement dans le processus SMB. Cela peut entraîner une indisponibilité des données (DU).

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Symptoms

Si le cluster est sur le code de version 9.7.1.0 - 9.7.1.6, ce problème peut l’affecter. Les principaux symptômes sont les suivants :

  • Les utilisateurs SMB ne peuvent pas accéder à certains ou à tous les nœuds.
  • Le service SMB sur certains ou tous les nœuds affiche un nombre élevé de connexions à l’état fermé . Bien que les connexions à l’état fermé puissent se produire pour diverses raisons, il s’agit également d’un symptôme associé à ce problème spécifique. Pour le vérifier, utilisez la commande suivante :
isi_for_array -X 'netstat -an | grep "\.445 " | grep CLOSED | wc -l' | sort -V 

Vous devez vous attendre à voir tous les « 0 » dans la sortie. Vous trouverez ci-dessous un exemple de cluster présentant ce problème :

MyCluster-1# isi_for_array -X 'netstat -an | grep "\.445 " | grep CLOSED | wc -l' | sort -V
MyCluster-1:       208
MyCluster-2:       425
MyCluster-3:      2228
MyCluster-4:       146
MyCluster-5:      5284
MyCluster-6:       964
  • L’audit est activé sur le cluster. Vérifiez à l’aide de cette commande :
isi audit settings global view | grep "Protocol Auditing"

MyCluster-1# isi audit settings global view | grep "Protocol Auditing"
     Protocol Auditing Enabled: Yes
  • Votre cluster exécute le code concerné : 9.7.1.0 - 9.7.1.6

Pour déterminer de manière concluante si votre cluster rencontre ce problème, soumettez une demande de service au support Dell. Ils peuvent vous aider à examiner le vidage mémoire SMB à partir du service LWIO. 

Cause

Ce problème se produit car le processus SMB ne charge pas correctement le audit_flt Pilote au démarrage. Ce problème se déclenche généralement lorsque le service SMB est redémarré, par exemple lors d’une mise à niveau de code ou d’un basculement et d’une restauration automatique entre clusters. Toutefois, cela peut se produire si le SMB est redémarré pour une raison quelconque.

Resolution

Pour atténuer le problème, redémarrez le service SMB. Dans des circonstances normales, un redémarrage SMB isolé devrait être suffisant :

MyCluster-1# killall -6 lwio

Cette opération peut être effectuée sur plusieurs nœuds avec isi_for_array. Vous trouverez ci-dessous un exemple de redémarrage du service SMB sur les nœuds 1 à 4 :

MyCluster-1# isi_for_array -n1-4 'killall -6 lwio'

Si cela ne résout pas le problème, il peut être nécessaire de redémarrer SMB et toutes les dépendances :

MyCluster-1# /usr/likewise/bin/lwsm restart lwio

Là encore, cette opération peut être effectuée simultanément sur plusieurs nœuds à l’aide de isi_for_array. Vous trouverez ci-dessous un exemple de redémarrage de la pile SMB sur les nœuds 1 à 4 :

MyCluster-1# isi_for_array -n1-4 '/usr/likewise/bin/lwsm restart lwio'

Ce problème est résolu dans le code OneFS 9.7.1.7 et versions ultérieures.

Affected Products

Isilon, PowerScale OneFS
Article Properties
Article Number: 000286634
Article Type: Solution
Last Modified: 22 Aug 2025
Version:  4
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