SyncIQ tuottaa virheen: Tiedostonimen tuettu enimmäispituus vaihtelee

Summary: SyncIQ-työ epäonnistuu, kun LFN (Long Filename) -tuki on käytössä lähde- tai kohdeklusterissa, mutta sitä ei ole otettu käyttöön vertaisklusterissa.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

SyncIQ tuottaa virheen: "Maximum file name length support differs between the source and target. Cannot sync a cluster with long file names to a target cluster without long name support enabled"

Cause

SyncIQ-työ epäonnistuu, jos LFN on käytössä vain yhdessä klusterissa, lähteessä tai kohteessa SyncIQ-suhteessa.
OneFS:ssä oletusarvoinen nimen pituus on 255 tavua ja 255 merkkiä. SyncIQ-suhteen molempien klustereiden on tuettava pitkiä tiedostonimiä (LFN), jotka ylittävät oletusarvon enimmäismäärän.

Resolution

Tarkista, onko LFN käytössä sekä lähde- että kohdeklustereissa:

HUOMAUTUS: Jos asetus on käytössä, sitä ei voi peruuttaa.

 

# isi_for_array -s 'sysctl efs.bam.long_file_name_enabled'

Tarkista SyncIQ:n lähde- ja kohdepolut LFN-asetuksesta:

# isi sync policies view <policy_name> |grep Path:
# isi namelength list

Ota LFN käyttöön klusterissa:

HUOMAUTUS: Jos asetus on käytössä, sitä ei voi peruuttaa.
 
# isi_sysctl_cluster efs.bam.long_file_name_enabled=1 --explanation="Enable LFN"

 

HUOMAUTUS: Joskus lähdeasetuksen peilaamiseen tarvitaan myös vastaava nimen pituusasetus.


Esimerkkikomento:

 

# isi namelength create --max-bytes xxxx --max-chars xxxx /ifs/<lfn_path>

Additional Information

LFN otettiin käyttöön OneFS 9.3 -versiossa.
Lisätietoja: http://www.unstructureddatatips.com/onefs-and-long-filenames/Tämä hyperlinkki johtaa Dell Technologiesin ulkopuoliseen sivustoon.

Affected Products

Isilon SyncIQ

Products

PowerScale
Article Properties
Article Number: 000343370
Article Type: Solution
Last Modified: 12 Nov 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.