Data Protection Advisor: Das Upgrade unter Windows schlägt fehl und .iawin32.dll nicht gefunden.

Summary: Das Upgrade von DPA auf einem Windows-Server schlägt fehl, weil eine iawin32.dll Datei fehlt. Die DPA-Version ist nicht relevant.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Das Upgrade von DPA auf einem Windows-Server schlägt aufgrund einer fehlenden Bibliotheksdatei fehl.

Application Exception Details: "...iawin32.dll not found":

Fehlerausgabe

Betriebssystem (BS): Windows 2025 64-Bit-Server

Das Installationsprogramm sucht nach einer Datei namens iawin32.dll. Der temporäre Speicherort des Installationsverzeichnispfads zeigt, dass die Datei vorhanden ist.

Cause

Die Ursache des Problems ist, dass keine Version von DPA mit Windows 2025 qualifiziert ist. Die neueste DPA-Version 19.12 SP1 wird noch nicht unterstützt. Das bedeutet, dass frühere Versionen ebenfalls nicht qualifiziert sind.

Referenz: DPA 19.12 SP1 – Kompatibilitätsleitfaden im E-Lab Navigator
DPA_19_12_SP1.pdf

Resolution

Der folgende Workaround kann angewendet werden:

  1. Legen Sie die Umgebungsvariable auf Windows 2019 fest:

C:\inst> SET JAVA_TOOL_OPTION=-Dos.name=”Windows 2019”

  1. Führen Sie das Upgrade erneut aus.

Affected Products

Data Protection Advisor
Article Properties
Article Number: 000361080
Article Type: Solution
Last Modified: 04 Dec 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.