Data Protection Advisor : La mise à niveau sous Windows échoue avec .iawin32.dll introuvable.

Summary: La mise à niveau de DPA sur un serveur Windows échoue avec un fichier iawin32.dll manquant. La version DPA n’est pas pertinente.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

La mise à niveau de DPA sur un serveur Windows échoue avec un fichier de bibliothèque manquant.

Application Exception Details: "...iawin32.dll not found":

Sortie d’erreur

Système d’exploitation (OS) : Serveur

Windows 2025 64 bits Le programme d’installation recherche un fichier appelé iawin32.dll. L’emplacement temporaire du chemin d’accès au répertoire du programme d’installation indique que le fichier est présent.

Cause

La cause du problème est qu’aucune version de DPA n’est qualifiée avec Windows 2025. La dernière version de DPA, 19.12 SP1, n’est pas encore prise en charge. Cela signifie que les versions précédentes ne sont pas non plus qualifiées.

Référence: Guide de compatibilité de DPA 19.12 SP1 sur E-Lab Navigator
DPA_19_12_SP1.pdf

Resolution

La solution de contournement suivante peut être appliquée :

  1. Définissez la variable d’environnement sur Windows 2019 :

C:\inst> SET JAVA_TOOL_OPTION=-Dos.name=”Windows 2019”

  1. Exécutez à nouveau la mise à niveau.

Affected Products

Data Protection Advisor
Article Properties
Article Number: 000361080
Article Type: Solution
Last Modified: 04 Dec 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.