OneFS-fejl: "Kunne ikke gendanne journal. Kontakt kundesupport med det samme"

Summary: Ved opstart starter en node ikke helt, og der vises en Journal-fejlmeddelelse.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

 Ved opstart starter en node ikke helt, og følgende fejlmeddelelse vises: "Could not recover journal. Contact Isilon Customer Support Immediately."

En node starter ikke korrekt.


En af følgende meddelelser kan blive vist på kommandolinjegrænsefladen under nodens startrækkefølge. 



Dårlig version: 0

Unable to save journal (isi_dumpjournal -s returned 1)
Error output:
    Writing v4/v5/v6 journal
     type       sector      bytes
    -----   ---------- ----------
    Bad version: 0
    isi_dumpjournal: Bad v4 superblock sect 0x0
Unable to save journal /var/journal/journal:
Restore failed
!! The journal test has encountered a problem.

!! Could not recover journal. Contact Isilon Customer Support
!! immediately.

!! Type 'prompt' to drop to a shell.
 
Journaltilstanden stemmer ikke overens med node- og klyngetilstanden.
 
Test Journal exited with error - Checking Isilon Journal integrity...
The journal state is internally consistent, but the journal state does not match the node and cluster state. Journal
: cluster guid 000000000000000000000000000000000000, device id 0. Disk: cluster guid 0007430733ba99650a52911df09ba81
ca8bc, device id 4. Contact Isilon Customer Support immediately.
Please contact Isilon Customer Support at 1-877-2-ISILON.
Command Options:
1) Enter recovery shell
2) Continue booting
3) Reboot
 

DRAM-kladde er ugyldig.

 
Test Journal exited with error - Checking Isilon Journal integrity...
Attempting to save journal to default location
Warning: /etc/ifs/journal_bad exists. Saving bad journal.
OneFS is unmounted
Writing journal_backup_valid : backup in progress
Writing journal_backup_serial : unmounted backup at Sun Oct 20 08:36:31 2013
Saving journal to /var/journal/journal.gz
Unable to save journal (isi_dumpjournal -s returned 1)
Error output:
data 422768 8192
data 787792 8192
data 617904 8192
Bad flags: 0xe01d
isi_dumpjournal: Bad v4 txn block sect 0x1a57f
Unable to save journal /var/journal/journal:
DRAM journal is invalid, initiating recovery...
Attempting to save and restore journal to clear any ECC errors in unused DRAM blocks...
Restore failed
Could not recover journal. Contact Isilon Customer Support immediately.
Please contact Isilon Customer Support at 1-877-2-ISILON.
Command Options:
1) Enter recovery shell
2) Continue booting
3) Reboot
 

Cause

Der blev registreret fejl i NVRAM-journalen, og noden kunne ikke gendanne eller finde en journalsikkerhedskopi. Kladder sporer filsystemets handlinger, før de bindes til disken. Under en normal nedlukning eller genstart af noden sikkerhedskopieres NVRAM-indholdet til disken.
 

Under en nodegenstart validerer OneFS NVRAM-journalen. Hvis NVRAM-journalen ikke indeholder gyldige data, forsøger noden at gendanne journalsikkerhedskopien fra startdisken. Hvis sikkerhedskopieringen også er ugyldig, stopper noden opstarten og viser en fejlmeddelelse.

Resolution

Løsningsproceduren varierer afhængigt af OneFS-beskyttelsesniveauet og antallet af offlineenheder i klyngen. Du kan finde flere oplysninger om beskyttelsesniveau i afsnittet "Oversigt over databeskyttelse" i OneFS-administrationsvejledningen.

  • Hvis antallet af offlineenheder i klyngen er under nodebeskyttelsesniveauet, skal noden med den inkonsistente kladde Smartfailed fra klyngen. Start SmartFailing noden, og kontakt Dells tekniske support for at få yderligere hjælp og indsamling af oplysninger.

    FORSIGTIG: Omformater ikke noden. Ved at omformatere noden reduceres mængden af oplysninger, der er tilgængelige for Dells tekniske support til diagnosticering.

  • Hvis antallet af offlineenheder i klyngen er over nodebeskyttelsesniveauet, kan data være utilgængelige eller gå tabt. Kontakt straks Dells tekniske support.

Affected Products

Isilon
Article Properties
Article Number: 000032508
Article Type: Solution
Last Modified: 28 Aug 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.