OneFS 錯誤:「無法復原紀錄。立即連絡客戶支援」
Summary: 開機後,節點無法完全啟動,並顯示日誌錯誤訊息。
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Symptoms
節點在開機後無法完全啟動,並顯示下列錯誤訊息: "Could not recover journal. Contact Isilon Customer Support Immediately."
節點未成功開機。
在節點的引導序列期間,命令行介面可能會顯示以下消息之一。
錯誤版本:0
Unable to save journal (isi_dumpjournal -s returned 1) Error output: Writing v4/v5/v6 journal type sector bytes ----- ---------- ---------- Bad version: 0 isi_dumpjournal: Bad v4 superblock sect 0x0 Unable to save journal /var/journal/journal: Restore failed !! The journal test has encountered a problem. !! Could not recover journal. Contact Isilon Customer Support !! immediately. !! Type 'prompt' to drop to a shell.
日誌狀態與節點和叢集狀態不相符。
Test Journal exited with error - Checking Isilon Journal integrity... The journal state is internally consistent, but the journal state does not match the node and cluster state. Journal : cluster guid 000000000000000000000000000000000000, device id 0. Disk: cluster guid 0007430733ba99650a52911df09ba81 ca8bc, device id 4. Contact Isilon Customer Support immediately. Please contact Isilon Customer Support at 1-877-2-ISILON. Command Options: 1) Enter recovery shell 2) Continue booting 3) Reboot
DRAM 日誌無效。
Test Journal exited with error - Checking Isilon Journal integrity... Attempting to save journal to default location Warning: /etc/ifs/journal_bad exists. Saving bad journal. OneFS is unmounted Writing journal_backup_valid : backup in progress Writing journal_backup_serial : unmounted backup at Sun Oct 20 08:36:31 2013 Saving journal to /var/journal/journal.gz Unable to save journal (isi_dumpjournal -s returned 1) Error output: data 422768 8192 data 787792 8192 data 617904 8192 Bad flags: 0xe01d isi_dumpjournal: Bad v4 txn block sect 0x1a57f Unable to save journal /var/journal/journal: DRAM journal is invalid, initiating recovery... Attempting to save and restore journal to clear any ECC errors in unused DRAM blocks... Restore failed Could not recover journal. Contact Isilon Customer Support immediately. Please contact Isilon Customer Support at 1-877-2-ISILON. Command Options: 1) Enter recovery shell 2) Continue booting 3) Reboot
Cause
在 NVRAM 日誌中偵測到錯誤,節點無法還原或找到日誌備份。日誌在文件系統操作提交到磁碟之前對其進行跟蹤。在節點正常關機或重新開機期間,NVRAM 內容會備份至磁碟。
在節點重新開機期間,OneFS 會驗證 NVRAM 日誌。如果 NVRAM 日誌不包含有效的數據,節點將嘗試從啟動磁碟還原日誌備份。如果備份也無效,節點將停止引導並顯示錯誤消息。
Resolution
解決方案程序會因 OneFS 保護等級和叢集中的離線裝置數量而有所不同。如需保護等級的詳細資訊,請參閱 OneFS 管理指南的「資料保護概觀」一節。
- 如果叢集中的離線裝置數量低於節點保護等級,則具有不一致日誌的節點必須在叢集中為 SmartFail。開始 SmartFail 節點,並聯絡 Dell 技術支援以取得其他協助和資訊收集。
警示:請勿重新設置節點的格式。重新格式化節點可減少 Dell 技術支援部門可用於診斷的資訊量。
- 如果叢集中的離線裝置數量超過節點保護等級,則資料可能無法使用或遺失。立即聯絡 Dell 技術支援部門。
Affected Products
IsilonArticle Properties
Article Number: 000032508
Article Type: Solution
Last Modified: 28 Aug 2025
Version: 4
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