ECS: Fejlfinding af problemer med ECS-ydeevnen

Summary: Fejlfinding af problemer med ECS-ydeevnen.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Sådan foretager du fejlfinding af problemer med ECS-ydeevnen.
 

Præstationsrelaterede problemer:

  • En eller flere typer operationer er langsomme. Dette er det mest almindelige problem, da problemet bemærkes fra slutapplikationer.
  • En eller flere noder er langsomme eller har høj ressourceudnyttelse. Dette kan være et spørgsmål, der rejses ved overvågningen af ECS, eller findes som en del af normal brug.

Cause

Flere faktorer såsom netværksrelaterede problemer, høj belastning og brugsmønstre og så videre.

Resolution

    Spørgsmål, du bør overveje, når du oplever en forringelse af ydeevnen. (Forvent, at teknisk support vil anmode om svar på nedenstående forespørgsler)

    • Hvilken adfærd eller symptomer opleves, der indikerer et ydelsesproblem?

    • Hvad er virkningen af problemet?

    • Hvornår blev ydelsesproblemer først bemærket?

    Noget ændrer sig for nylig i miljøet?

    • Software eller hardware?
    • Læs?
    • Netværk?
    • Brandmur?
    • Load Balancer?
    • Kan problemet udtrykkes i form af latenstid eller driftstid
    • Hvad er miljøet? Software og hardware, der bruges? Versioner? Konfiguration? Kundeansøgning?
    • Hvad er den gennemsnitlige filstørrelse (store og små filer)?
    • Påvirkes læsninger, skrivninger, sletninger eller opdateringer? Eller alle berørte metoder?
    • Mulighed for at læse eller skrive ved hjælp af andre Access-metoder? Er et specifikt program berørt, eller er alle applikationer berørt?

    Hvilken adgangsmetode bruges:
    • S3
    • Hurtig
    • Centera SDK (CAS) Er der en transformation/ECSsync eller anden migrering i gang?
    • Adgang til filsystemet:
    • Windows ved hjælp af CIFS (geodrive)
    • Linux ved hjælp af NFS
    Hvad er programadgangsmønsteret?
    POST opretter og/eller omdøber objekter.
    GET henter objektdata.
    PUT opdaterer objektattributter
    DELETE fjerner objekter og metadata fra systemet.
    HEAD svarer til hver GET-metode. HEAD ligner nøjagtigt en GET-anmodning, bortset fra at metodenavnet er HEAD i stedet for GET.
    Svaret på en HEAD-anmodning omfatter kun overskrifter. Det omfatter ikke et indsatsorgan.
    • Opretter din applikation forbindelse til alle eller nogle individuelle noder? Er der konfigureret en belastningsbalancer?

    • Kan navneområdet leveres, Bucket secret og UID for det berørte program, så vi kan bruge udføre lignende tests på ECS?

     

    Oplysninger, der skal indsamles på ECS, hvis du åbner en SR med teknisk support for at hjælpe med at indsnævre problemløsning

    • Programlogfiler fra berørte programmer, der er specifikke for en mislykket anmodning eller forsinket anmodning, er mest nyttige her.
    • Eventuelle observationer fra ECS-brugergrænsefladen som i en node offline eller andre kritiske fejl observeret fra dashboardmenuen
    • Svar på spørgsmål fra forrige afsnit
    • Xdoctor kører, hvis det berørte system ikke har DialHome-funktion.

    Affected Products

    Elastic Cloud Storage

    Products

    ECS Appliance, Elastic Cloud Storage
    Article Properties
    Article Number: 000053707
    Article Type: Solution
    Last Modified: 30 Sept 2025
    Version:  5
    Find answers to your questions from other Dell users
    Support Services
    Check if your device is covered by Support Services.