ECS: Resolución de problemas de rendimiento de ECS
Summary: Resolución de problemas de rendimiento de ECS.
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Symptoms
Cómo solucionar problemas de rendimiento de ECS.
Problemas relacionados con el rendimiento:
- Uno o más tipos de operaciones están lentas. Este es el problema más común, ya que se observa en las aplicaciones finales.
- Uno o más nodos están lentos o usan muchos recursos. Esta podría ser una pregunta planteada por el monitoreo del ECS, o encontrarse como parte del uso normal.
Cause
Varios factores, como problemas relacionados con la red, alta cantidad de carga, patrones de uso, etc.
Resolution
Preguntas que se deben tener en cuenta si se experimenta una degradación del rendimiento. (Espere que el soporte técnico solicite respuestas a las consultas que aparecen a continuación)
-
¿Qué comportamiento o síntomas se experimentan que indican un problema de rendimiento?
-
¿Qué impacto tiene el problema?
-
¿Cuándo se notó por primera vez el problema de rendimiento?
¿Hubo algún cambio reciente en el entorno?
- ¿Hubo cambios de software o hardware?
- ¿Hubo cambios en la carga?
- ¿Hubo cambios en la red?
- ¿Hubo cambios en el firewall?
- ¿Hubo cambios en el balanceador de carga?
- ¿Se puede expresar el problema en términos de latencia o tiempo de ejecución?
- ¿Cuál es el entorno? ¿Qué software y hardware se utilizan? ¿Qué versiones se utilizan? ¿Cuál es la configuración? ¿Se trata de aplicación del cliente?
- ¿Cuál es el tamaño promedio de los archivos (archivos grandes y pequeños)?
- ¿Se ven afectadas las lecturas, las escrituras, las eliminaciones o las actualizaciones? ¿Se ven afectados todos los métodos?
- ¿Cuál es la capacidad de lectura o escritura mediante otros métodos de acceso? ¿Se ve afectada una aplicación específica o se ven afectadas todas las aplicaciones?
Qué método de acceso se usa:
- S3
- Swift
- SDK de Centera (CAS) ¿Hay una transformación/ECSsync u otra migración en curso?
- Acceso al sistema de archivos:
- Windows con CIFS (GeoDrive)
- Linux con NFS
POST crea o cambia el nombre de los objetos.
GET recupera los datos de los objetos.
PUT actualiza los atributos de los objetos
DELETE elimina objetos y metadatos del sistema.
HEAD corresponde a cada método GET. HEAD luce exactamente igual que una solicitud GET, excepto que el nombre del método es HEAD en lugar de GET.
La respuesta para una solicitud HEAD incluye solo encabezados; no incluye una estructura de respuesta.
GET recupera los datos de los objetos.
PUT actualiza los atributos de los objetos
DELETE elimina objetos y metadatos del sistema.
HEAD corresponde a cada método GET. HEAD luce exactamente igual que una solicitud GET, excepto que el nombre del método es HEAD en lugar de GET.
La respuesta para una solicitud HEAD incluye solo encabezados; no incluye una estructura de respuesta.
-
¿La aplicación se conecta a todos los nodos o a algunos nodos individuales? ¿Hay configurado un balanceador de carga?
-
¿Se pueden proporcionar el espacio de nombres, la contraseña del depósito y el UID de la aplicación afectada para que podamos realizar pruebas similares en ECS?
Información que se debe recopilar en ECS si se abre una SR con el soporte técnico para ayudar a acotar la resolución de problemas
- En este caso, los registros de aplicaciones de las aplicaciones afectadas específicas de una solicitud fallida o con retraso son los más beneficiosos.
- Todas las observaciones a partir de la interfaz de usuario de ECS, como en un nodo offline, u otras fallas críticas se observan desde el menú del panel
- Respuestas a las preguntas de la sección anterior
- XDoctor se ejecuta si el sistema afectado no tiene funcionalidad de marcación.
Affected Products
Elastic Cloud StorageProducts
ECS Appliance, Elastic Cloud StorageArticle Properties
Article Number: 000053707
Article Type: Solution
Last Modified: 30 Sept 2025
Version: 5
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