Isilon OneFS: Oznámení události: Node Offline - ID události: 200010001, 300010003, 399990001, 900160001, 910100006, 400150007
Summary: Isilon OneFS: Oznámení události: Node Offline - ID události: 200010001, 300010003, 399990001, 900160001, 910100006, 400150007
Symptoms
Událost
Zobrazí se oznámení události „Node Offline“. Event ID: 200010001.
Události „Node Offline“ se generují, když je uzel nahlášen ostatními uzly v clusteru jako „Offline“. Tato událost může být také vygenerována, když dojde ke ztrátě interního propojení na libovolném uzlu.
POZNÁMKA: Pokud uzel není zapnutý, proveďte postup "Jak uzel Isilon vypnout a vyprázdnit ".
Cause
Podrobnosti
Platí jedna z následujících podmínek:
- Byl restartován jeden nebo více uzlů.
- Je vypnutý jeden nebo více uzlů.
- Uzel postrádá konektivitu se sítí back-end (InfiniBand (IB)). (Konektivita back-end znamená schopnost uzlu komunikovat s ostatními uzly.)
- Uzel se nemůže připojit ke skupině.
Resolution
Reakce
Než začnete s odstraňováním problému, ověřte, zda událost nesouvisí s údržbou clusteru. Jakmile zkontrolujete, že zrovna neprobíhá žádná údržba, pokračujte následujícím odstraňováním problémů.
Pokud byl uzel restartován:
- Navažte připojení SSH s uzlem a přihlaste se pomocí účtu „root“.
- Zadáním následujícího příkazu potvrďte, že se uzel znovu připojil ke clusteru:
Stav
isi Příkaz isi status vrátí výstup podobný následujícímu. Pokud se uzel úspěšně znovu připojil ke clusteru, ve sloupci Health se nezobrazí údaj D (mimo provoz):
Propustnost ve stavu (b/s) Úložiště HDD ID úložiště
SSD |IP adresa |DASR | Celkem za výstup| Použité / Velikost|Ojeté / Velikost
-------------------+-----+-----+-----+-----+-----------------+-----------------
1|10.111.183.10 | OK | 115 tis. | 220 tis. | 335 tis. | 531M / 10T (< 1%) | (Bez disků SSD)
2|10.111.183.11 | OK | 0| 0| 0| 519M / 10T (< 1%) | (Bez disků SSD)
3|10.111.183.12 | OK | 0| 26 tis. | 26 tis. | 521M / 10T (< 1%) | (Bez disků SSD)
-------------------+-----+-----+-----+-----+-----------------+-----------------
Celkem clusterů: | 115 tis. | 246 tis. | 361 tis. ot. 1,5 G / 31 vláken (< 1 %) | (Bez disků SSD)
Zdravotní obory: D = Down, A = Attention, S = Smartfailed, R = Read-Only
- Zadejte následující příkaz a potvrďte dobu provozu:
uptime
Zobrazí se výstup podobný následujícímu:
8:41PM up 10 mins, 1 user, load averages: 0,08, 0,18, 0,14
Pokud se uzel nedávno restartoval, doba provozu bude relativně krátká, v několika minutách.
- Spuštěním následujícího příkazu shromážděte protokoly a odešlete je technické podpoře Isilon na analýzu:
isi_gather_info
Pokud je možné na externí IP adresu uzlu mimo provoz odeslat příkaz ping
- Zkontrolujte stav uzlu:
- Navažte připojení SSH s uzlem a přihlaste se pomocí účtu „root“.
- Zadejte následující příkaz:
ifconfig |grep -A4 ib1
Příkaz ifconfig by měl vrátit následující stav, což znamená, že interní rozhraní je aktivní:
ib1: příznaky=8843<NAHORU, VŠESMĚROVÉ VYSÍLÁNÍ, BĚŽÍCÍ, SIMPLEXNÍ, VÍCESMĚROVÉ VYSÍLÁNÍ> metrické 0 MTU 2004
lladdr 0.15.1b.0.10.BD.4C.77
inet 172.10.111.200 Maska sítě 0xffffff00 vysílání 1.10.111.255 zóna 1
média: Stav automatického výběru
Infiniband: aktivní
- Pokud je stav „inactive“, zkontrolujte následující skutečnosti:
- Svítí kontrolky aktivity portů na kartě IB, nebo jsou zhasnuté?
- Pokud jsou kontrolky zhasnuté, přejděte ke kroku b.
- Jsou kabely IB pevně připojeny k uzlu a přepínači IB?
- Pokud tomu tak není, znovu kabely připojte k uzlu a přepínači.
- Je přepínač IB zapnutý?
- Pokud ne, zapněte jej.
- Vizuálně zkontrolujte uzel a ověřte, že svítí kontrolka napájení.
- Svítí kontrolky aktivity portů na kartě IB, nebo jsou zhasnuté?
Pokud je uzel vypnutý
- Pokuste se uzel zapnout.
POZNÁMKA: Nejlepší je, když můžete navázat sériový přístup k uzlu, který bude sledovat při spouštění, a zachytit veškeré informace, které by mohly pomoci při odstraňování problémů. Další informace najdete v článku Isilon: Jak se připojit k portu pro správu uzlu. - Pokud se uzel zapne, zkontrolujte, zda se znovu připojil ke clusteru:
- Navažte připojení SSH (Secure Shell) s jiným uzlem v clusteru a přihlaste se pomocí účtu uživatele „root“.
- Zadáním následujícího příkazu určete, zda se uzel znovu připojil ke clusteru:
Stav
isi Příkaz isi status vrátí výstup podobný následujícímu. Pokud se uzel úspěšně znovu připojil ke clusteru, ve sloupci Health se nezobrazí údaj D (mimo provoz):
Propustnost ve stavu (b/s) Úložiště HDD ID úložiště
SSD |IP adresa |DASR | Celkem za výstup| Použité / Velikost|Ojeté / Velikost
-------------------+-----+-----+-----+-----+-----------------+-----------------
1|10.111.183.10 | OK | 115 tis. | 220 tis. | 335 tis. | 531M / 10T (< 1%) | (Bez disků SSD)
2|10.111.183.11 | OK | 0| 0| 0| 519M / 10T (< 1%) | (Bez disků SSD)
3|10.111.183.12 | OK | 0| 26 tis. | 26 tis. | 521M / 10T (< 1%) | (Bez disků SSD)
-------------------+-----+-----+-----+-----+-----------------+-----------------
Celkem clusterů: | 115 tis. | 246 tis. | 361 tis. ot. 1,5 G / 31 vláken (< 1 %) | (Bez disků SSD)
Zdravotní obory: D = Down, A = Attention, S = Smartfailed, R = Read-Only
- Pokud se uzel ke clusteru znovu připojil, spuštěním následujícího příkazu shromážděte protokoly a odešlete je technické podpoře Isilon na analýzu:
isi_gather_info
- Pokud se uzel ke clusteru znovu nepřipojil, pokračujte další částí.
- Pokud se uzel nezapne, zkontrolujte, zda jsou funkční jističe a aktivní elektrické zásuvky.
- Pokud uzel není napájen, vyřešte problém se zdrojem napájení.
- Pokud je uzel vypnutý a je napájen, obraťte se na technickou podporu společnosti Isilon, která vám s řešením problému pomůže.
Pokud je uzel zapnutý, ale ke clusteru se znovu nepřipojil
- Pokuste se navázat vzdálený přístup prostřednictvím relace SSH (Secure Shell). Pokud relace SSH selže, pokuste se navázat vzdálený přístup pomocí sériové konzole.
- Pokud nereaguje relace SSH, ani sériová konzole, stiskněte v relaci SSH nebo v sériové konzoli klávesy CTRL+T.
- Pokud se po stisknutí kláves CTRL+T zobrazí výstup, zaznamenejte si jej a poté kontaktujte technickou podporu společnosti Isilon ohledně analýzy selhání.
- Pokud uzel nereaguje, stiskněte třikrát tlačítko napájení a poté počkejte pět minut, než se uzel vypne.
- Pokud se uzel nevypne, stiskněte a podržte tlačítko napájení, dokud se uzel nevypne.
- Opakovaným stisknutím tlačítka napájení uzel znovu zapněte.
- Pokud se uzel spustí a zobrazí výzvu k přihlášení, přihlaste se pomocí účtu „root“.
- Shromážděte protokoly spuštěním následujícího příkazu a odešlete je technické podpoře Isilon k analýze
isi_gather_info
- Pokud se uzel ke clusteru znovu nepřipojí, obraťte se na technickou podporu Isilon, která vám s řešením problému pomůže.
Additional Information
ID události: 200010002 - NODE_STATUS_ONLINE
ID události: 200010003 - XTND_OFFLINE
ID události: 200010005 - DISKNODE_OFFLINE
ID události: 299990001 - NODE_COALESCE
ID události: 300020001 - RO_TRANS_FAILED
ID události: 300010002 - NODE_SHUTDOWN
ID události: 300020002 - NODE_REBOOT_JRNL_BKUP_FAIL
Chyba OneFS: Nelze obnovithttps://www.dell.com/support/kbdoc/32508
deníku
Jak bezpečně vypnout cluster Isilon před plánovaným výpadkem
napájeníhttps://www.dell.com/support/kbdoc/18989
ID události: 300010003 - BOOT_TIMEOUT
ID události: 399990001 - MAINT_REBOOT_COALESCE
ID události: 300020003 - MAINT_REBOOT_SHUTDOWN_FAILED
ID události: 300010001 - NODE_REBOOT