ECS : Dial Home : ObjectGCObjectCleanup - Symptom Code : 1313 et 1314

Summary: Il s’agit d’un appel à distance introduit dans ECS 3.2.1.0 pour détecter Alerte.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Un ECS a composé un appel à distance avec l’alerte suivante.
Description: CAS La vitesse de nettoyage des objets de traitement est lente.
 
Code de symptôme Gravité
1313 AVERTISSEMENT
1314 ERREUR

Exemple d’alerte :
<?xml version="1.0" encoding="UTF-8"?>
<ConnectHome SchemaVersion="1.0.8"
    xsi:schemaLocation="/opt/connectemc/schema/ema_ConnectHome108.xsd" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <TransType>10</TransType>
    <TransTypeDesc>EventXML</TransTypeDesc>
    <TransID>0</TransID>
    <Node Status="Unknown" State="Unknown" ID="ECSQE00079">
        <Identifier>
            <DeviceState>1</DeviceState>
            <DeviceStatus>1</DeviceStatus>
            <ClarifyID>ECSQE00079</ClarifyID>
            <SiteName>UNKNOWN</SiteName>
            <Vendor>EMC</Vendor>
            <DeviceType>ElasticCloudStorageApp</DeviceType>
            <Model>ElasticCloudStorage</Model>
            <SerialNumber>ECSQE00079</SerialNumber>
            <WWN>ECSQE00079</WWN>
            <Platform>platform</Platform>
            <OS>SLES</OS>
            <OS_VER>12.3</OS_VER>
            <UcodeVer>3.3.0.0-4349.d0de882</UcodeVer>
            <EmbedLevel>2</EmbedLevel>
            <InternalMaxSize>512800</InternalMaxSize>
            <Comment>Object Alert</Comment>
        </Identifier>
        <Connection>
            <ConnectType>ESRS</ConnectType>
            <IPName>austin-burlywood.ecs.lab.emc.com</IPName>
            <ConnectNum>169.254.109.16</ConnectNum>
            <Port>22</Port>
        </Connection>
        <HeartBeat>
            <HBStatus></HBStatus>
            <HBState></HBState>
        </HeartBeat>
        <InternalData>
            <FileList/>
            <EventList>
                <Event>
                    <SymptomCode>1314</SymptomCode>
                    <Category>Configuration</Category>
                    <Severity>Error</Severity>
                    <Status>Unknown</Status>
                    <Component>Object</Component>
                    <ComponentID></ComponentID>
                    <SubComponent>CAS Processing Object Cleanup</SubComponent>
                    <SubComponentID></SubComponentID>
                    <CallHome>true</CallHome>
                    <FirstTime>2019-01-28T22:15:30.182Z</FirstTime>
                    <LastTime>2019-01-28T22:15:30.182Z</LastTime>
                    <Count>0</Count>
                    <EventData><![CDATA[]]></EventData>
                    <Description><![CDATA[CAS Processing object cleanup speed is slow.  [Ref_ID : ObjectGCObjectCleanup]]]></Description>
                </Event>
            </EventList>
        </InternalData>
        <ExternalFiles/>
    </Node>
</ConnectHome>

Cause

ECS dispose d’anciennes tâches de nettoyage d’objets CAS GC non traitées, ce qui peut déclencher l’alerte de démarrage CAS lent.

Resolution

Remarque : Il existe un problème dans les versions d’ECS inférieures à 3.5 qui provoque une alerte pour ce capteur en l’absence de suppression. Même s’il n’y a pas d’espace à récupérer. 

Connectez-vous à l’un des nœuds d’ECS via SSH.
  1. Vérifiez l’état actuel du capteur :
# svc_rest_cmd /vdc/sensor/status/ObjectGCObjectCleanup
Exemple :
#  svc_rest_cmd /vdc/sensor/status/ObjectGCObjectCleanup
svc_rest_cmd 1.0.10

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<SensorStatusList>
  <SensorId>ObjectGCObjectCleanup</SensorId>
  <ListSensorStatus>
    <SensorStatusRestRep>
      <ContextId>ObjectGCObjectCleanup</ContextId>
      <CurrentState>OK</CurrentState>
      <NodeId>1f4368c3-37cd-467f-9efc-289264806ea0</NodeId>
      <PreviousState>OK</PreviousState>
      <Time>1551118064264</Time>
    </SensorStatusRestRep>
  </ListSensorStatus>
<SensorStatusList>
<Recherchez CurrentState>, s’il est défini sur OK, ce qui signifie que l’erreur n’est pas active et que vous pouvez fermer la demande de service. Si <CurrentState> n’est pas OK (avertissement ou erreur), poursuivez le dépannage.
 
  1. Vérifiez si CAS GC est activé, si l’objet est activé et si dry_run est défini sur false
Commande :
# svc_param list com.emc.ecs.objectgc | grep -e cas.enabled -e dry_run -e object.enabled
Exemple :
com.emc.ecs.objectgc.cas.enabled                                   Enable or disable CAS GC                                       true
com.emc.ecs.objectgc.cas.process_object.dry_run                    If enabled then delete marker insertion will be skipped a...   *false
com.emc.ecs.objectgc.cas.process_object.enabled                    Enable or disable GC process object                            true
Si vos valeurs de configuration ne correspondent pas aux éléments ci-dessus, ouvrez une demande de service et consultez cet article de la base de connaissances.

Additional Information

RÉFLEXIONS:
CAS GC récupère les objets blob associés aux clips supprimés (également appelés réflexions). Dans ECS, les éléments et les objets blob sont considérés comme des objets. Lorsqu’un clip est supprimé, il devient une réflexion qui contient des informations d’audit, telles que le moment où l’appel de suppression a été effectué et à partir de quelle adresse IP.
Certaines applications conservent ces informations pour toujours. La taille typique du clip ou de la réflexion est en Ko, de sorte que peu d’espace est consommé par les réflexions. 

Si vous préférez également récupérer les réflexions, ils doivent définir l’expiration des réflexions pour le bucket CAS.
Cette opération peut être effectuée à partir de l’interface utilisateur ECS (Manage>Buckets, sélectionnez namespace, > puis cliquez sur Edit Bucket).   Accédez à l’onglet Required et activez Reflection Expirationet définissezReflection Age.

Pour supprimer un compartiment CAS, les réflexions doivent être expirées, car elles sont toujours considérées comme des objets dans le compartiment.

Affected Products

ECS, ECS Appliance, ECS Appliance Gen 1, ECS Appliance Gen 2, ECS Appliance Gen 3, ECS Appliance Hardware Gen1 U-Series, ECS Appliance Hardware Gen1 C-Series, ECS Appliance Hardware Gen2 C-Series, Elastic Cloud Storage

Products

ECS Appliance Hardware Gen3 EX300, ECS Appliance Hardware Gen3 EX3000, ECS Appliance Hardware Gen2 D-Series, ECS Appliance Hardware Gen2 U-Series, ECS Appliance Hardware Gen3 EX500, ECS Appliance Hardware Gen3 EXF900, ECS Appliance Hardware Series , ECS Appliance Software with Encryption, ECS Appliance Software without Encryption, Elastic Cloud Storage ...
Article Properties
Article Number: 000061341
Article Type: Solution
Last Modified: 17 Dec 2025
Version:  11
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.