ECS: Dial Home: ObjectGCObjectCleanup - Codice sintomo: 1313 e 1314

Summary: Si tratta di una connessione dial-home introdotta in ECS 3.2.1.0 per rilevare Vigile.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Un ECS ha effettuato una chiamata a casa con il seguente avviso.
Descrizione: La velocità di pulizia degli object di elaborazione CAS è lenta.
 
Codice sintomo Gravità
1313 WARNING
1314 ERROR

Esempio di avviso:
<?xml version="1.0" encoding="UTF-8"?>
<ConnectHome SchemaVersion="1.0.8"
    xsi:schemaLocation="/opt/connectemc/schema/ema_ConnectHome108.xsd" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <TransType>10</TransType>
    <TransTypeDesc>EventXML</TransTypeDesc>
    <TransID>0</TransID>
    <Node Status="Unknown" State="Unknown" ID="ECSQE00079">
        <Identifier>
            <DeviceState>1</DeviceState>
            <DeviceStatus>1</DeviceStatus>
            <ClarifyID>ECSQE00079</ClarifyID>
            <SiteName>UNKNOWN</SiteName>
            <Vendor>EMC</Vendor>
            <DeviceType>ElasticCloudStorageApp</DeviceType>
            <Model>ElasticCloudStorage</Model>
            <SerialNumber>ECSQE00079</SerialNumber>
            <WWN>ECSQE00079</WWN>
            <Platform>platform</Platform>
            <OS>SLES</OS>
            <OS_VER>12.3</OS_VER>
            <UcodeVer>3.3.0.0-4349.d0de882</UcodeVer>
            <EmbedLevel>2</EmbedLevel>
            <InternalMaxSize>512800</InternalMaxSize>
            <Comment>Object Alert</Comment>
        </Identifier>
        <Connection>
            <ConnectType>ESRS</ConnectType>
            <IPName>austin-burlywood.ecs.lab.emc.com</IPName>
            <ConnectNum>169.254.109.16</ConnectNum>
            <Port>22</Port>
        </Connection>
        <HeartBeat>
            <HBStatus></HBStatus>
            <HBState></HBState>
        </HeartBeat>
        <InternalData>
            <FileList/>
            <EventList>
                <Event>
                    <SymptomCode>1314</SymptomCode>
                    <Category>Configuration</Category>
                    <Severity>Error</Severity>
                    <Status>Unknown</Status>
                    <Component>Object</Component>
                    <ComponentID></ComponentID>
                    <SubComponent>CAS Processing Object Cleanup</SubComponent>
                    <SubComponentID></SubComponentID>
                    <CallHome>true</CallHome>
                    <FirstTime>2019-01-28T22:15:30.182Z</FirstTime>
                    <LastTime>2019-01-28T22:15:30.182Z</LastTime>
                    <Count>0</Count>
                    <EventData><![CDATA[]]></EventData>
                    <Description><![CDATA[CAS Processing object cleanup speed is slow.  [Ref_ID : ObjectGCObjectCleanup]]]></Description>
                </Event>
            </EventList>
        </InternalData>
        <ExternalFiles/>
    </Node>
</ConnectHome>

Cause

ECS dispone di attività di pulizia degli oggetti GC CAS obsolete non elaborate e ciò potrebbe attivare l'avviso GC CAS lento.

Resolution

Nota: Si verifica un problema nelle versioni ECS precedenti alla 3.5 che causa un avviso per questo sensore se non si verificano eliminazioni. Anche se non c'è spazio da recuperare. 

Connettersi a uno dei nodi in ECS tramite SSH.
  1. Verificare lo stato corrente del sensore:
# svc_rest_cmd /vdc/sensor/status/ObjectGCObjectCleanup
Esempio:
#  svc_rest_cmd /vdc/sensor/status/ObjectGCObjectCleanup
svc_rest_cmd 1.0.10

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<SensorStatusList>
  <SensorId>ObjectGCObjectCleanup</SensorId>
  <ListSensorStatus>
    <SensorStatusRestRep>
      <ContextId>ObjectGCObjectCleanup</ContextId>
      <CurrentState>OK</CurrentState>
      <NodeId>1f4368c3-37cd-467f-9efc-289264806ea0</NodeId>
      <PreviousState>OK</PreviousState>
      <Time>1551118064264</Time>
    </SensorStatusRestRep>
  </ListSensorStatus>
<SensorStatusList>
<Cercare CurrentState>, se è impostato su OK, significa che l'errore non è attivo e si può chiudere la SR. Se <CurrentState> non è OK (avvertenza o errore), procedere con la risoluzione dei problemi.
 
  1. Verificare che GC CAS sia abilitato, che l'object sia abilitato e che dry_run impostato su false
Comando:
# svc_param list com.emc.ecs.objectgc | grep -e cas.enabled -e dry_run -e object.enabled
Esempio:
com.emc.ecs.objectgc.cas.enabled                                   Enable or disable CAS GC                                       true
com.emc.ecs.objectgc.cas.process_object.dry_run                    If enabled then delete marker insertion will be skipped a...   *false
com.emc.ecs.objectgc.cas.process_object.enabled                    Enable or disable GC process object                            true
Se i valori di configurazione non corrispondono a quelli riportati sopra, aprire una SR e fare riferimento a questo articolo della Knowledge Base.

Additional Information

RIFLESSIONI:
GC CAS recupera i blob associati ai clip eliminati (chiamati anche riflessi). In ECS, sia le clip che i blob sono considerati oggetti. Quando una clip viene eliminata, diventa un riflesso che contiene informazioni di audit, ad esempio quando è stata effettuata la chiamata di eliminazione e da quale IP.
Alcune applicazioni conservano queste informazioni per sempre. La dimensione tipica del ritaglio o del riflesso è in KB, quindi non viene utilizzato molto spazio dai riflessi. 

Se si preferisce recuperare anche i riflessi, è necessario impostare Reflection Expiration per il bucket CAS.
Questa operazione può essere eseguita dall'interfaccia utente di ECS (ManageBuckets > Selezionare namespace e cliccare su Edit Bucket. Passare alla scheda Required e abilitare Reflection Expiration e impostare ReflectionAge.

Per eliminare un bucket CAS, i riflessi devono essere scaduti, in quanto sono ancora considerati oggetti nel bucket.

Affected Products

ECS, ECS Appliance, ECS Appliance Gen 1, ECS Appliance Gen 2, ECS Appliance Gen 3, ECS Appliance Hardware Gen1 U-Series, ECS Appliance Hardware Gen1 C-Series, ECS Appliance Hardware Gen2 C-Series, Elastic Cloud Storage

Products

ECS Appliance Hardware Gen3 EX300, ECS Appliance Hardware Gen3 EX3000, ECS Appliance Hardware Gen2 D-Series, ECS Appliance Hardware Gen2 U-Series, ECS Appliance Hardware Gen3 EX500, ECS Appliance Hardware Gen3 EXF900, ECS Appliance Hardware Series , ECS Appliance Software with Encryption, ECS Appliance Software without Encryption, Elastic Cloud Storage ...
Article Properties
Article Number: 000061341
Article Type: Solution
Last Modified: 17 Dec 2025
Version:  11
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.