VNX1シリーズ: CSのハードウェア障害後にVNX Data Moverのフェールオーバーが発生しませんでした
Summary: VNX1シリーズ: CSのハードウェア障害後にVNX Data Moverのフェールオーバーが発生しなかった(ユーザー修正可能)
Symptoms
単一Control Stationアレイのハードウェア障害
VNX Control Stationの障害が発生し、ハードウェアが交換される前に障害が発生しました。障害が発生しました。この障害により、通常はData Moverのフェールオーバーがトリガーされるはずですが、Data Moverのフェールオーバーは発生しませんでした。
Cause
単一のControl Stationを持つアレイでは、Control Stationでハードウェア障害が発生して、アレイ管理のためのNAS Control Stationサービスが起動不能になったり、正常に実行できなかったりした場合、通常はData Moverのフェールオーバーをトリガーする後続のイベントは発生しません。NAS Control Stationとその管理サービスは、Data Moverのフェールオーバーを実行するために必要です。動作不能なControl Station、またはNASサービスが停止状態のControl Stationでは、Data Moverのフェールオーバーをトリガーできません。
デュアルControl Station構成では、プライマリーControl Stationのサービスまたはハードウェアに障害が発生すると、スタンバイ ピアControl Stationが強制的にプライマリーControl Stationとしての役割を引き継ぎます。これは、ピアControl Stationが管理ハートビートに対する応答を受信できない場合、またはハートビート応答がタイムアウト値を超えた場合にトリガーされます。
Resolution
オンラインのControl Stationの場合は、「nas_checkup」コマンドを実行して、ハードウェア障害またはソフトウェア障害が報告されているかどうかを確認します。ハードウェア障害が発生した場合は、VNXサポートと連携して解決する必要があります。ソフトウェアの問題に関する警告は、Dellナレッジベースを使用して解決できる場合があります https://support.emc.com/
可能であれば、常にControl Stationでサポート資料の収集を実行して、変更する前にログと現在の状態を収集して、必要に応じて分析できるようにします。
ハードウェア障害を具体的にチェックするには、次のコマンドのみを使用できます。エンクロージャのステータスについては、Data Moverのエンクロージャ番号を(-e)の後に指定します
$ nas_inventory -tree
$ /nas/sbin/enclosure_status -e 0 -v
Additional Information
その他の参考資料:
VNX Control Stationでこの診断用Zipファイルを生成する手順は次のとおりです。
[サポート資料の収集]
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VNX NASからサポート資料の収集(診断バンドル)を生成するには、SSH経由で接続され、nasadminとしてログインしているControl Stationで、次のスクリプトを実行します。
$ /nas/tools/collect_support_materials
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スクリプトが完了すると、Zipファイルが生成され、このファイルの名前と場所が画面に表示されます
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Control Stationからワークステーションにファイルをダウンロードするには、WinscpなどのSCPクライアントが必要です。収集サポート資料を生成するControl Station上のデフォルトの場所は/nas/var/emcsupportです。
注:古いコレクト サポート資料は自動的に削除され、必要に応じて/nas/var/emcsupportに空き領域が確保されます。
Celerra: Control Stationのフェールオーバー タイムアウト値を増やす方法。
https://support.emc.com/kb/331802 (この記事を表示するにはDellサポート アカウントが必要です)
CelerraおよびVNX File Data Moverのフェールオーバーの手順 (この記事を表示するにはDellサポート アカウントが必要です)