VNX1 系列:CS 硬體故障後未發生 VNX 資料移動者容錯移轉

Summary: VNX1 系列:CS 的硬體故障後,沒有發生 VNX 資料移動者容錯移轉 (使用者可修正)

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

單一控制站陣列中的硬體故障

發生 VNX 控制站故障,在更換硬體之前發生故障,這應觸發資料移動者容錯移轉,但並未發生資料移動者容錯移轉。

 

Cause

若為單一控制站的陣列,當控制站發生硬體故障,導致其無法啟動或無法正確執行用於管理陣列的 NAS 控制站服務時,任何通常會觸發資料移動者容錯移轉的後續事件將不會觸發。必須使用 NAS 控制站及其管理服務來執行資料移動者容錯移轉。無法運作的控制站或 NAS 服務處於停止狀態的控制站無法觸發資料移動者容錯移轉。

在雙控制站配置中,主控制站服務或硬體的故障將導致備用對等控制站強制接管主控制站的角色,當對等控制站無法接收對其管理活動訊號的回應或心跳回應超過超時值時觸發。

 

Resolution

若為線上控制站 請執行「nas_checkup」命令 確認是否有任何回報的硬體故障或軟體故障回報如果發生硬體故障,應聯絡 VNX 支援以解決問題。您可以使用 Dell 知識庫 https://support.emc.com/ 解決軟體問題的警告

請務必盡可能在控制站上執行收集支援資料,以在變更之前擷取記錄和目前狀態,以便在需要時進行分析。

為了專門檢查硬體故障,只能使用以下命令,對於機櫃狀態,在 (-e) 之後指定資料移動器機櫃編號

$ nas_inventory -tree
$ /nas/sbin/enclosure_status -e 0 -v

 

Additional Information

更多參考資料:
在 VNX 控制站上產生此診斷 Zip 檔案的程序如下:

[收集支援資料]

  1. 若要從 VNX NAS 產生收集支援資料 (診斷套裝),請以 SSH 連線並以 nasadmin 身分登入時,在控制站上執行下列指令檔。

    $ /nas/tools/collect_support_materials
  2. 指令檔完成後,會產生 Zip 檔案,並在螢幕上顯示此檔案的名稱和位置

  3. 必須有 Winscp 等 SCP 用戶端才能將檔案從控制站下載到您的工作站,控制站上可產生收集支援資料的預設位置為 /nas/var/emcsupport。

    注意:若舊版收集支援資料在 /nas/var/emcsupport 中需要,會自動刪除以騰出空間。

Celerra:如何提高控制站容錯移轉逾時值。
https://support.emc.com/kb/331802 (需要有 Dell 支援帳戶才能檢視此文章)
Celerra 和 VNX 檔案資料移動者容錯移轉的程序 (需要有 Dell 支援帳戶才能檢視此文章)

 

Affected Products

VNX1 Series

Products

VNX1 Series, VNX2 Series, VNX5200, VNX5300, VNX5400, VNX5500, VNX5600, VNX5700, VNX5800, VNX7500, VNX7600, VNX8000
Article Properties
Article Number: 000061849
Article Type: Solution
Last Modified: 20 Oct 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.