VxRail: host link does not automatically come up

Summary: After a single fiber or RJ45 cable is disconnected then reconnect to the host, the network link remains down.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

After one of the Internet connection cables either fiber or RJ45 is disconnected from a host and is reconnected, the link does not automatically come back up.
The link light does light up on the unit.

Through an SSH session to the host, running the following causes the link to work again:

# esxcli network nic up -n vmnic0

 

Cause

NIC 'configured speed' must be 'auto negotiated' not set to a speed.
 

Resolution

1. Confirm that the Configurated Speed is wrong in vCenter Web Client.

     a. Enter host and cluster view
     b. Click the host in question
     c. Click 'Configure'
     d. Click 'Physical Adapters

In the Physical Adapters view, find the 'Device' and the 'Configured Speed' row.

NOTE: Ignore the 'Actual Speed' row.



Under Devices find vmnic0 and vmnic1.
Look at the 'Configured Speed' for vmnic0 and 1, if it gives a speed such as '10000 Mb' the device is not being 'auto negotiated'.

On the host using SSH, run the following commands:

 

# esxcli network nic set -a -n vmnic0
# esxcli network nic set -a -n vmnic1


This sets the NICs to auto negotiate.

Look back on the Physical Adapters page in vCenter and refresh the page.
The 'Configured Speed' should now say 'auto negotiated'.

When a cable is disconnected and reconnected, the NIC should now come back up automatically on the host.

Videos

Affected Products

VxRail Appliance Family

Products

VxRail Appliance Family, VxRail Appliance Series, VxRail Software
Article Properties
Article Number: 000062737
Article Type: Solution
Last Modified: 27 Feb 2025
Version:  4
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