Isilon: InsightIQ: Los informes de clientes muestran un rendimiento cero para algunos clientes de manera intermitente

Summary: Cuando se ve el desglose o el filtrado de un cliente específico en un informe, el rendimiento de un cliente a veces puede mostrar un valor de cero.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Cuando se observa un informe en InsightIQ y se filtra para un cliente específico o se desglosa por clientes, en general, se producen períodos intermitentes en los que se informa un rendimiento nulo. Para un cliente, o incluso a pesar de que ese cliente está realizando I/O en el clúster de OneFS, se ve.

Cause

El motor de estadísticas de OneFS no puede realizar un seguimiento exhaustivo de todos los clientes conectados a cada nodo. En su lugar, el motor de estadísticas realiza un seguimiento de forma predeterminada de los 256 clientes principales que realizan I/O. Esto puede dar lugar a una situación en la que uno o varios clientes específicos realicen suficientes operaciones de I/O como para estar entre los 256 clientes principales periódicamente. Cuando esto ocurre, InsightIQ solo puede informar sobre los intervalos en los que ese cliente o clientes se encuentran en la lista de los 256 principales. Los intervalos en los que el cliente o los clientes no están en la lista de 256 principales se informan como cero.

Resolution

PRECAUCIÓN: Aumentar la cantidad de clientes rastreados por el motor de estadísticas de OneFS consume más recursos del clúster y puede afectar negativamente el rendimiento del cliente.

Las estadísticas de los clientes se desglosan por protocolo; ajuste la cantidad específica de clientes rastreados para cada protocolo de manera independiente.

Para ver una lista de todas las listas de clientes ajustables por protocolo, ejecute el siguiente comando desde la CLI del clúster de OneFS:   

# sysctl -a | egrep "isi.stats.client.*.max_clients"


A continuación, se muestra un ejemplo de la salida de OneFS 8.0.0.7:   

isi01-1# sysctl -a | egrep "isi.stats.client.*.max_clients"
isi.stats.client.nfs.max_clients: 256
isi.stats.client.cifs.max_clients: 256
isi.stats.client.nlm.max_clients: 256
isi.stats.client.ftp.max_clients: 256
isi.stats.client.http.max_clients: 256
isi.stats.client.siq.max_clients: 256
isi.stats.client.iscsi.max_clients: 256
isi.stats.client.jobd.max_clients: 256
isi.stats.client.smb2.max_clients: 256
isi.stats.client.nfs4.max_clients: 256
isi.stats.client.papi.max_clients: 256
isi.stats.client.irp.max_clients: 256
isi.stats.client.lsass_out.max_clients: 256
isi.stats.client.hdfs.max_clients: 256


Para aumentar la cantidad de clientes rastreados para un protocolo específico, utilice el sysctl que se correlaciona con el protocolo dado.

La cantidad máxima de clientes que OneFS puede rastrear es 4096.

Atención: La variable sysctl nombrado isi.stats.client.cifs.max_clients es para el protocolo SMB 1.

(Solo los clientes registrados de Dell pueden acceder al contenido en el siguiente enlace, a través de Dell.com/support)
Para obtener instrucciones sobre cómo ajustar ese sysctl y hacer que persista en los reinicios y las actualizaciones, consulte el artículo de la base de conocimientos 462759: OneFS: La configuración de sysctls y la realización de cambios en sysctl persisten a través de reinicios y actualizaciones de nodos y clústeres.       

Esto permite que las estadísticas de isi rastreen más clientes. Pero pase lo que pase, establezca el valor en on en OneFS IIQ. Esto muestra un máximo de 150 clientes en la interfaz de usuario y 255 en la exportación csv. Ya que este es un número codificado de forma rígida en InsightIQ para el desglose. Se está rastreando como una característica futura para que estos números aumenten o funcionen en cohesión con la configuración de OneFS. 

Affected Products

Isilon InsightIQ, PowerScale OneFS
Article Properties
Article Number: 000081922
Article Type: Solution
Last Modified: 20 Oct 2025
Version:  7
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.