MD Series: Redistribute Virtual Disk(s) - MD32xx/MD34xx/MD36xx/MD38xx

Summary: How to Redistribute Virtual Disks on a MD32xx, MD34xx, MD36xx and MD38xx.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

When the Recovery Guru on the MDSM shows the error "Virtual Disk Not On Preferred Path" you should manual redistribute the virtual disks.

Cause

When data comes to a redundant, dual Controller MD3000(i) over 5 minutes via the nonpreferred path, the failover controller will start to handle the traffic direct but with the error message "Virtual Disk Not On Preferred Path".
This can have different causes, like a failed connection, changed in the fabric (storage network with iSCSI), the wrong MPIO driver, an unsupported operating system, etc.

Resolution

To redistribute the Virtual Disks of a MD32xx, MD34xx, MD36xx or MD38xx (SAS + F + I) do the following steps.
>> Be aware that minimum the Firmware 07.80.62.60 need to be installed on MD32xx/MD36xx.
  1. Open the Modular Disk Storage Manager (MDSM).
  2. Connect to the storage.
  3. Select the menu Storage.
  4. After that click on Virtual Disk.
  5. Now a submenu appear, click on Advanced.
  6. Than you see another submenu where you have to select Redistribute Virtual Disks... 
    SLN316662_en_US__1Redistri3xxx
     
  7. If you select Yes you will see a new window where you can follow the redistributing.

Affected Products

Dell PowerVault MD3600f/3620f Windows HA Cluster, Dell PowerVault OEM Ready MD34XX and MD38XX, PowerVault MD3200, PowerVault MD3200i, PowerVault MD3220, PowerVault MD3220i, PowerVault MD3260, PowerVault MD3260i, PowerVault MD3400, PowerVault MD3420 , PowerVault MD3460, PowerVault MD3600F, PowerVault MD3600i, PowerVault MD3620F, PowerVault MD3620i, PowerVault MD3660f, PowerVault MD3660i, PowerVault MD3800f, PowerVault MD3800i, PowerVault MD3820f, PowerVault MD3820i, PowerVault MD3860f, PowerVault MD3860i ...
Article Properties
Article Number: 000124704
Article Type: Solution
Last Modified: 03 Nov 2022
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.