Een of meer gedeelde clustervolumes van Storage Spaces Direct (S2D) raken los of gaan offline

Summary: Dit artikel biedt de oplossing wanneer een of meer gedeelde clustervolumes van storageruimten losraken of offline gaan.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Inhoudsopgave


1. Beschrijving
2. Oplossing
3. Meer informatie

 

SLN315780_en_US__1icon Opmerking: Dit artikel maakt deel uit van de zelfstudies van de server: Supporttools.

 

Beschrijving

In een S2D-cluster met meerdere knooppunten, wanneer een of meer knooppunten uitvallen. Ofwel gepland door het knooppunt in onderhoudsmodus te zetten of ongepland vanwege onverwachte uitval. Een of meer Cluster Shared Volumes (CSV) kunnen losgekoppeld of offline raken. Dit is onverwacht omdat het cluster de fout zou moeten kunnen verwerken als deze binnen het fouttolerantieontwerp valt.

 

Cause

De losgekoppelde operationele status kan optreden als het DRT-logboek (Dirty Region Tracking) vol is. Storage Spaces gebruikt DRT voor gespiegelde ruimtes, zodat als er een stroomstoring optreedt. Alle actieve updates van metadata worden gelogd, zodat de storageruimte bewerkingen opnieuw kan uitvoeren of ongedaan kan maken om de storagespace weer in een flexibele en consistente staat te brengen wanneer de voeding wordt hersteld en het systeem weer actief wordt. Als het DRT-logboek vol is, kan de virtuele schijf pas online worden gebracht nadat de DRT-metadata zijn gesynchroniseerd en leeggemaakt. Voor dit proces moet een volledige scan worden uitgevoerd. Dit proces kan enkele uren in beslag nemen en is een offline proces.

 

Resolution

Oplossing

 

Om te bepalen of u het DRT full probleem ondervindt, kunt u kijken naar de aanvullende DRT-tellers die in de cumulatieve update van oktober zijn geïntroduceerd om ervoor te zorgen dat het DRT-logboek niet vol is voordat u het opnieuw start. Er zijn twee manieren om dit te controleren:

 

  1. Er is een gebeurtenis-id 1023 aanwezig in het Microsoft-Windows-StorageSpaces-Driver/Diagnostic-gebeurtenislogboek waarin de gebeurtenisgegevens NumberOfEntries gelijk zijn aan de gebeurtenisgegevens van de limiet . Dit duidt op een DRT volledig scenario. Een voorbeeld DRT volledig, ID 1023 gebeurtenis:

 

Log Name:      Microsoft-Windows-StorageSpaces-Driver/Diagnostic

Bron:        Microsoft-Windows-StorageSpaces-Driver

Gebeurtenis-ID:      1023

Niveau:         Warning

Trefwoorden:     

Gebruiker:          SYSTEEM

Computer:      nodename.domain.int

Beschrijving:

Voor inwendig gebruik.

Event Xml:

<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">

  <Systeem>

    <Provider Name="Microsoft-Windows-StorageSpaces-Driver" Guid=" " />

    <EventID>1023</EventID>

    <Versie>0</Versie>

    <Niveau>3</Niveau>

    <Taak>0</Taak>

    <Opcode>0</Opcode>

    <Trefwoorden>0x4000000000000000</Trefwoorden>

    <EventRecordID>1394776</EventRecordID>

    <Correlatie/>

    <Execution ProcessID="9248" ThreadID="3820" />

    <Channel>Microsoft-Windows-StorageSpaces-Driver/Diagnostic</Channel>

    <Computer>nodename.domain.int</Computer>

    <Security UserID="S-1-5-18" />

  </Systeem>

  <EventData>

    <Data Name="SpaceId"></Data>

    <Data Name="NumberOfEntries">386</Data>

    <Data Name="Limit">386</Data>

  </EventData>

</Gebeurtenis>

            

  1. Een andere manier om erachter te komen of DRT vol is, is door te controleren of het aantal synchronisaties in de Perfmon-tellers gelijk is aan de grenswaarde.  In het onderstaande voorbeeld is het aantal synchronisaties (0) niet gelijk aan de limiet (255).  De DRT is in dit geval niet vol.

 

SLN315780_en_US__2SLN315780-DRT

 

 


Meer informatie

 

Dell en Microsoft raden aan om de oplossing toe te passen die openbaar beschikbaar is via KB4480977 (https://support.microsoft.com/en-us/help/4480977/windows-10-update-kb4480977).

  

 

SLN315780_en_US__1icon Opmerking: Als het DRT-logboek vol is, volgt u de instructies voor het uitvoeren van de Data Integrity Scan en storageonderhoudsmodus om knooppunten af te sluiten/opnieuw op te starten, zoals beschreven in KB4294480 en in het S2D-document voor probleemoplossing.

   

SLN315780_en_US__1icon Opmerking: zie het bijgevoegde document voor meer informatie over het bijwerken van patches.

 

Affected Products

Dell EMC Ready Solution Resources, Enterprise Solution Resources, Servers Solution Resources
Article Properties
Article Number: 000134753
Article Type: Solution
Last Modified: 29 Jul 2025
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.