Uno o más volúmenes compartidos de clúster de Storage Spaces Direct (S2D) se desconectan o quedan offline
Summary: En este artículo, se proporciona una solución para casos en que uno o más volúmenes compartidos de clúster de Storage Spaces Direct se desconectan o quedan offline.
Symptoms
Tabla de contenido
1. Descripción
2. Solución
3. Más información
Nota: Este artículo es parte de los tutoriales del servidor: Herramientas de soporte.
Descripción
En un clúster S2D de múltiples nodos, cuando uno o más nodos se desactivan. Ya sea planificado mediante la colocación del nodo en modo de mantenimiento o no planificado debido a una interrupción inesperada. Uno o más volúmenes compartidos de clúster (CSV) pueden desconectarse o quedar offline. Esto es inesperado, ya que se supone que el clúster puede manejar la falla si se encuentra dentro del diseño de tolerancia a fallas.
Cause
El estado operativo desconectado puede ocurrir si el registro de rastreo de regiones con errores (DRT) está lleno. Storage Spaces utiliza DRT para espacios en espejo en caso de que se produzca una falla de alimentación. Todas las actualizaciones en transferencia de metadatos se registran, lo que garantiza que el espacio de almacenamiento pueda realizar operaciones de reconstitución o deshacer para que el espacio de almacenamiento vuelva a un estado flexible y coherente, cuando se restaure la alimentación y el sistema vuelve a encenderse. Si el registro de DRT está lleno, el disco virtual no se puede poner en línea hasta que los metadatos de DRT se sincronicen y se vacíen. Ese proceso requiere la ejecución de un análisis completo, que puede tardar varias horas en finalizar y es un proceso offline.
Resolution
Solución
A fin de determinar si está experimentando el problema completo de DRT, puede ver los contadores de DRT adicionales que se presentan en la actualización acumulativa de octubre para asegurarse de que el registro de DRT no esté lleno antes de reiniciarlo. Hay dos maneras de hacer esto:
-
Hay un ID de evento 1023 presente en el registro de eventos de diagnóstico en Microsoft-Windows-StorageSpaces-Driver/Diagnostic, donde los datos de evento de NumberOfEntries son iguales a los datos de evento de Limit. Esto indica una situación en que el DRT está lleno. Un ejemplo de DRT lleno, ID de evento 1023:
Nombre del registro: Microsoft-Windows-StorageSpaces-Driver/Diagnostic
Origen: Microsoft-Windows-StorageSpaces-Driver
ID de evento: 1023
Nivel: Advertencia
Palabras clave:
Usuario: SISTEMA
Computadora: nodename.domain.int
Descripción:
Para uso interno.
Xml del evento:
<Evento xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<Sistema>
<Nombre del proveedor = "Microsoft-Windows-StorageSpaces-Driver" guid=" " />
<ID de>evento 1023</ID de evento>
<Versión>0</Versión>
<Nivel>3</Nivel>
<Tarea>0</Tarea>
<Código de>operación 0</Código de operación>
<Palabras>clave 0x4000000000000000</Palabras clave>
<ID>de registro de evento 1394776</ID de registro de evento>
<Correlación/>
<ID de proceso de ejecución="9248" ThreadID="3820" />
<Canal>Microsoft-Windows-StorageSpaces-Driver/Diagnostic</Channel>
<Computadora>nodename.domain.int</Computadora>
<ID de usuario de seguridad="S-1-5-18" />
</Sistema>
<Datos del evento>
<Nombre de datos = "SpaceId"></datos>
<Nombre de datos = "NumberOfEntries">386</Data>
<Nombre de datos = "Límite">386</Datos>
</Datos del evento>
</Evento>
- Otra manera de averiguar si DRT está lleno es comprobar si el conteo de sincronización en los contadores de Perfmon es igual al valor de Limit. En el siguiente ejemplo, el conteo de sincronización (0) no es igual al de Limit (255). En este caso, el DRT no está lleno.

Más información
Dell y Microsoft recomiendan aplicar la corrección que está disponible públicamente a través de KB4480977 (https://support.microsoft.com/en-us/help/4480977/windows-10-update-kb4480977).
Nota: Si el registro de DRT está lleno, siga las instrucciones sobre cómo ejecutar el análisis de integridad de datos y el modo de mantenimiento de almacenamiento para apagar/reiniciar los nodos, como se describe en KB4294480 y en el documento Solución de problemas de S2D.
Nota: Consulte el documento adjunto para obtener detalles sobre la actualización de parches.