Un ou plusieurs volumes partagés de cluster Storage Spaces Direct (S2D) se détachent ou sont hors ligne
Summary: Cet article donne une solution lorsqu’un ou plusieurs espaces de stockage direct de volumes partagés en cluster sont détachés ou hors ligne.
Symptoms
Sommaire
1. Description
2. Solution
3. Autres informations
Remarque : Cet article fait partie des didacticiels de serveur : Outils de support.
Description
Dans un cluster S2D à plusieurs nœuds, lorsqu’un ou plusieurs nœuds tombent en panne, que ce soit de manière planifiée en mettant le nœud en mode maintenance ou de manière non planifiée en raison d’une panne inattendue, un ou plusieurs volumes partagés de cluster (CSV) peuvent se détacher ou être hors ligne. Ce problème est inattendu puisque le cluster est censé être capable de gérer la panne s’il elle comprise dans la tolérance aux pannes.
Cause
L’état de fonctionnement détaché peut se produire si le journal DRT (Dirty Region Tracking) est plein. Les espaces de stockage utilisent un DRT pour les espaces en miroir afin de le faire en cas de coupure d’alimentation. Toutes les mises à jour en cours de transfert des métadonnées sont consignées, ce qui garantit que l’espace de stockage peut rétablir ou annuler des opérations visant à rétablir l’espace de stockage dans un état flexible et cohérent, lorsque l’alimentation est rétablie et que le système redémarre. Si le journal DRT est plein, le disque virtuel ne peut pas être mis en ligne tant que les métadonnées DRT ne sont pas synchronisées et vidées. Ce processus nécessite l’exécution d’une analyse complète, qui peut prendre plusieurs heures et se déroule hors ligne.
Resolution
Solution
Pour déterminer si vous rencontrez le problème DRT complet, vous pouvez consulter les compteurs DRT supplémentaires introduits dans la mise à jour cumulative d’octobre afin de vous assurer que le journal DRT n’est pas plein avant de le redémarrer. Il y a deux manières le vérifier :
-
Un ID d’événement 1023 est présent dans le journal d’événements Microsoft-Windows-StorageSpaces-Driver/Diagnostic où les données d’événement NumberOfEntries sont égales aux données d’événement Limit. Cela indique un scénario DRT complet. Exemple de DRT complet avec ID d’événement 1023 :
Log Name: Microsoft-Windows-StorageSpaces-Pilote/Diagnostic
Source : Microsoft-Windows-StorageSpaces-Driver
ID d’événement : 1 023
Niveau : Warning
Mots clés :
Utilisateur : SYSTEM
Ordinateur : nodename.domain.int
Description:
For internal use.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event »>
<Système>
<Provider name="Microsoft-Windows-StorageSpaces-Driver » guid= » " />
<ID d’événement>1023</ID d’événement>
<Version>0</Version>
<Niveau>3</Niveau>
<Tâche>0</Tâche>
<Opcode>0</Opcode>
<Mots-clés>0x4000000000000000</Mots-clés>
<EventRecordID>1394776</EventRecordID>
<Corrélation/>
<Execution ProcessID="9248 » ThreadID="3820 » />
<Canal>Microsoft-Windows-StorageSpaces-Driver/Diagnostic/Canal<>
<Ordinateur>nodename.domain.int</Ordinateur>
<Security UserID="S-1-5-18 » />
</Système>
<Données d’événement>
<Data Name="SpaceId »></Data>
<Data Name="NumberOfEntries">386</Data>
<Data Name="Limit">386</Data>
</EventData>
</Événement>
- Une autre façon de savoir si le DRT est plein est de vérifier si le nombre de synchronisations dans les compteurs Perfmon est égal à la valeur Limit. Dans l’exemple ci-dessous, le nombre de synchronisations (0) n’est pas égal à la valeur Limit (255). Dans ce cas, le DRT n’est pas plein.

Autres informations
Dell et Microsoft recommandent d’appliquer le correctif accessible au public via l’article KB4480977 (https://support.microsoft.com/en-us/help/4480977/windows-10-update-kb4480977).
Remarque : si le journal DRT est plein, veuillez suivre les instructions sur l’exécution de l’analyse de l’intégrité des données et du mode de maintenance du stockage pour arrêter/redémarrer les nœuds, comme décrit dans l’article KB4294480 et dans la documentation Dépannage S2D.
Remarque : reportez-vous au document joint pour plus d’informations sur la mise à jour des correctifs.