PowerFlex 2.x GUI viser ingen informasjon om frontend eller backend

Summary: ScaleIO-grensesnittet viser ingen informasjon om frontend eller backend

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Problembeskrivelse

Etter noen dager til noen uker viser serverdel- og frontendvisningene i brukergrensesnittet bare et lasteikon i stedet for forventet informasjon. 

Scenario

Brukergrensesnittet begynner å henge i lasting av SDS-, SDC- og volumvisningene etter at det har gått litt tid.

Symptomer

Følgende skjermbilder er det som kan sees i frontend- eller backend-visningene når dette problemet oppstår:

frontend 

grafisk brukergrensesnitt 

 

I brukergrensesnittloggene fra "%appdata%\EMC\scaleio\logs\log.txt" kan tusenvis av følgende forekomme:

java.util.concurrent.TimeoutException: Kunne ikke oppnå fullstendig svar fra QueryPoll i 10 000 forespørsler

 

Innvirkning

Kan ikke administrere eller overvåke ScaleIO-systemet fra brukergrensesnittet.  

Cause

Årsaken til dette problemet er når det er tusen+ opprettelser og slettinger av volumer (vtrees) over en tidsperiode der antall volumer som fortsatt eksisterer i ScaleIO-systemet er over 1000+. Dette påvirker UI FilterController som brukes av BaseTreeTablePanel som brukes av både backend- og frontend-visninger, og bestemmer også når backend- og frontend-visningene endelig vises. Siden brukergrensesnittet aldri får en komplett modell, fortsetter lastebildet å spinne til modellen er fullastet.

Denne typen problemer kan sees i OpenStack-implementeringer, siden det er mange opprettings-/kart-/tilordnings-/slettehendelser på volumer på grunn av øyeblikksbildene i OpenStack. 

Resolution

 

Den nåværende løsningen er å bytte MDM-eierskap med sci: 

scli --switch_mdm_ownership --new_master_mdm_id <ID of Slave MDM>

 

Berørte versjoner

2.0.1.3, 2.0.1.4, 2.5, 2.6

Løst i versjon

2.6.1, 3.0

Article Properties
Article Number: 000164011
Article Type: Solution
Last Modified: 28 Aug 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.