RecoverPoint for Virtual Machines : Impossible de déployer le serveur de plug-ins après la mise à niveau

Summary: Impossible de déployer le serveur plugin après la mise à niveau vers RP4VM 5.3 Une solution de contournement pour permettre aux utilisateurs de terminer l’Assistant Configurer le serveur de plug-ins. ...

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Symptoms

La tentative de configuration du serveur de plug-ins après la mise à niveau vers RecoverPoint for Virtual Machines (RP4VM,) 5.3 échoue. Le message suivant ou similaire est reçu :     
 

L’interface utilisateur de RecoverPoint for VM affichant le message d’erreur « Configure plugin server failed »


Les impressions de l’appliance RecoverPoint suivantes sont observées sous /home/kos/RPServers/RPServers_logs/clusterLogic:     
 

XXXX/XX/XX 16:55:22.519 [pool-3-thread-18] (FapiUtils.java:249) DEBUG - ArraySettings were extracted: [VCArraySettings [super=ArraySettings [name=XXXXXX, serialNumber=XXXXXXXX,arrayUID=ArrayUID [id=XXXXXXX, clusterUID=ClusterUID [id=8391617211477977355]], type=VC, credentials=VcCredentials [super=BaseCredentials [username=XXXX, password=[XXXX], certificate=],connectionParams=VcConnectionParams [super=BaseConnectionParams [mgmtIP=IPInformation [ipVersion=IPV_4, ip=XXX.XXX.XXX.XXX, dhcp=false, networkMask=]], port=XXX], resourcePools=null], registeredEsxClusters=[EsxCluster[esxClusterUID=EsxClusterUID [uuid=XXXXXXXX], name=Production Cluster, virtualCenterUID=VirtualCenterUID [uuid=XXXXXX]]]]]


Les impressions de l’appliance RecoverPoint suivantes sont observées sous /home/kos/installationLogs/server.log:     


XXXX-XX-XX 14:44:19,541 [CommandWorker-38] (ValidateVcCredentialsCommand.java:27) ERROR - Got exception while trying to verify Credentials com.emc.recoverpoint.connectors.vi.certificate.CommunicationException: Something wrong with the certificate
 at com.kashya.installation.server.commands.vsphere.ValidateVcCredentialsCommand.verifyCertificate(ValidateVcCredentialsCommand.java:43) ~[classes/:?]
 at com.kashya.installation.server.commands.vsphere.ValidateVcCredentialsCommand.execute(ValidateVcCredentialsCommand.java:25) [classes/:?]eadPoolFactory.java:43) [classes/:?] at java.lang.Thread.run(Thread.java:748) [?:1.8.0_251]
 Caused by: java.security.cert.CertificateParsingException: Could not generate certificate: Invalid certificate encoding.
 at com.rsa.cryptoj.o.pb.a(Unknown Source) ~[cryptojcommon.jar:6.2.0.1]
 at com.rsa.cryptoj.o.pb.engineGenerateCertificate(Unknown Source) ~[cryptojcommon.jar:6.2.0.1]
 at java.security.cert.CertificateFactory.generateCertificate(CertificateFactory.java:339) ~[?:1.8.0_251]
 at com.emc.recoverpoint.utils.javainfra.keytool.CertificationUtils.translateCertificate(CertificationUtils.java:544) ~[java_infra.jar:?]
 at com.emc.recoverpoint.utils.javainfra.keytool.CertificationUtils.verifyServerCertificate(CertificationUtils.java:523) ~[java_infra.jar:?]
 at com.kashya.installation.server.commands.vsphere.ValidateVcCredentialsCommand.verifyCertificate(ValidateVcCredentialsCommand.java:41) ~[classes/:?]

Cause

La commande CLI update_storage_registration rencontre actuellement un problème. Lorsqu’elle est exécutée, elle remplace le certificat vCenter résidant sur toutes les vRPA de ce cluster par une valeur nulle. Cela se produit dans les paramètres vRPA et ArrayConfiguration.xml situés sous /home/kos.

L’assistant de configuration du serveur de plug-ins WDM utilise ce certificat, déjà stocké dans les paramètres, pour établir une connexion au vCenter. Lorsqu’il tente de valider les informations d’identification, puisqu’aucun certificat n’existe, l’Assistant échoue.

Resolution

Solution de contournement :      
S’abstenir d’utiliser update_storage_registration

Avant toute mise à niveau, ou si ce problème se produit, exécutez la commande CLI update_vcenter_server_registration pour mettre à jour les informations d’identification. Vous pouvez également mettre à jour ces informations à partir de l’interface utilisateur Flash/Flex de RP4VM à partir de la section de configuration de vCenter.

Remédiation:     
Une solution existe à ce problème, mais l’intervention du personnel du support technique Dell EMC est requise. Contactez le Centre de support client Dell EMC ou votre responsable de compte pour obtenir une assistance technique et consultez cet ID de solution de la base de connaissances Dell Technologies.

Affected Products

RecoverPoint for Virtual Machines
Article Properties
Article Number: 000180847
Article Type: Solution
Last Modified: 08 Jul 2025
Version:  2
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