IDPA: La recopilación de datos falla en DPA después de una reimplementación de DPA

Summary: En este artículo de la base de conocimientos, se proporcionan instrucciones para resolver problemas de recolección de datos de DPA después de volver a implementar el DPA de IDPA.

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Symptoms

La DPA se volvió a implementar en el sistema IDPA, pero no hay datos en los informes. Los intentos de ejecutar la recolección de datos de depuración fallan.

El dpaagent.log se detuvo o muestra el mensaje "las colas de almacenamiento y reenvío están llenas". Esto indica que el agente no puede comunicarse con el servidor de la aplicación.
 

Cause

El agente ha perdido la conexión con el servicio de la aplicación. Se desconoce la causa.

Resolution

NOTA: Se agregó una solución para este problema a la herramienta goidpa. Siga el artículo de la base de conocimientos que aparece a continuación para instalar goidpa:
A continuación, ejecute el siguiente comando en ACM:
./goidpa dpa agent-register

 

Si el comando goidpa no resuelve esto, configure manualmente y vuelva a registrar el agente con el servidor de APP con el siguiente procedimiento. 
 

  1. En la interfaz de usuario de DPA, vaya a Administrator>System>Configure System Settings. En el cuadro emergente, haga clic en la flecha junto a Data Collection Agents para expandir la lista. Resalte el agente que se está utilizando, la aplicación o el servidor de recolección de datos independiente. A continuación, haga clic en el botón Remove Agent .


La interfaz de usuario de DPA va a Administrador>Sistema>Configurar ajustes del sistema 

 
En IDPA 2.6 o DPA 19.3, vaya a Agentes de recopilación de> datos, resalte el agente y haga clic en el botón Configuración del agente de recopilación de datos. A continuación, haga clic en el botón Remove Agent.
 IDPA 2.6 o DPA 19.3 vaya a Agentes de recolección de>datos  
 
  1. Inicie sesión en el servidor de la aplicación DPA y vaya a /opt/emc/dpa/services/bin directory y ejecute los siguientes comandos:

           
./dpa.sh app agentpassword
                      
Ingrese una contraseña (generalmente IDPA Common Password) y confírmela. 
           
 ./dpa.sh app restart 
  1. Inicie sesión en el servidor del agente DPA (para DP 4400, este es el servidor de aplicaciones).
    1. Vaya a /opt/emc/dpa/agent/etc y ejecute lo siguiente:
                              
vi dpaagent_config.xml                               
#Check the <servername> tag, is this the DPA APP IP address? If it is not then change to the DPA APP IP. Once this is the DPA APP IP save and exit.
                         
./dpa stop
 
    1. Vaya a /opt/emc/dpa/agent/data y ejecute lo siguiente:
                        
mkdir olddata
mv * olddata/

           
    1. Vaya a /opt/emc/dpa/agent/etc y ejecute lo siguiente:
                       
 ./dpa start 

           
    1. Vaya a /opt/emc/dpa/agent/bin y ejecute lo siguiente:
                       
./dpaagent --set-credentials           
#put in the passwork you set in step 2, confirm the password 
           
    1. Vaya a /opt/emc/dpa/agent/etc y ejecute lo siguiente:

                       
 ./dpa start 

           
    1. Vaya a /opt/emc/dpa/agent/logs Y compruebe el dpaagent.log para ver si hay algún error después del reinicio.

 

  1. Vuelva a abrir la interfaz de usuario de DPA y vaya a Administrator>System>Configure System Settings. En el cuadro emergente, haga clic en la flecha junto a Data Collection Agents para expandir la lista. Vea si el agente vuelve a aparecer.

Vaya a la pestaña Inventory>Object Library>Applications. Seleccione Avamar y haga clic en el botón Properties . En el cuadro emergente Properties , haga clic en la pestaña Data Collection . Seleccione Avamar Job Monitor collections y haga clic en el botón history. Compruebe si la última recolección de datos se realizó correctamente.


Comuníquese con el soporte de Dell si tiene alguna pregunta.

Affected Products

Integrated Data Protection Appliance Family

Products

Data Protection Advisor, PowerProtect Data Protection Software
Article Properties
Article Number: 000181653
Article Type: Solution
Last Modified: 02 Dec 2025
Version:  3
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