IDPA. Сбой сбора данных в DPA после повторного развертывания DPA

Summary: В этой статье базы знаний приведены инструкции по устранению проблем со сбором данных DPA после повторного развертывания DPA IDPA.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

DPA был повторно развернут в системе IDPA, но данных в отчетах нет. Попытки запустить отладочный сбор данных завершаются сбоем.

Окно dpaagent.log остановлено или отображается сообщение «очереди хранения и пересылки заполнены». Это указывает на то, что агент не может установить связь с сервером приложений.
 

Cause

Агент потерял подключение к службе приложений. Причина неизвестна.

Resolution

ПРИМЕЧАНИЕ. Исправление этой проблемы было добавлено в инструмент goidpa. Для установки goidpa следуйте приведенным ниже инструкциям в статье базы знаний:
Затем выполните следующую команду в ACM:
./goidpa dpa agent-register

 

Если команда goidpa не устраняет проблему, вручную настройте и повторно зарегистрируйте агент на сервере приложений, выполнив следующую процедуру. 
 

  1. В пользовательском интерфейсе DPA перейдите в раздел Administrator>System>Configure System Settings. Во всплывающем окне нажмите стрелку рядом с пунктом Агенты сбора данных , чтобы развернуть список. Выделите используемый агент, приложение или отдельный сервер сбора данных. Затем нажмите кнопку Remove Agent .


Пользовательский интерфейс DPA: перейти в раздел «Administrator>System>Configure System Settings» 

 
В IDPA 2.6 или DPA 19.3 перейдите враздел«Агенты сбора> данных», выделите агент и нажмите кнопку «Настройки агента сбора данных». Затем нажмите кнопку Remove Agent.
 IDPA 2.6 или DPA 19.3 перейти к агентам сбора>данных  
 
  1. Войдите на сервер приложений DPA и перейдите в /opt/emc/dpa/services/bin directory и выполните следующие команды:

           
./dpa.sh app agentpassword
                      
Введите пароль (обычно это общий пароль IDPA) и подтвердите его. 
           
 ./dpa.sh app restart 
  1. Выполните вход на сервер агента DPA (для DP 4400 это сервер приложений).
    1. Выберите /opt/emc/dpa/agent/etc и выполните следующую команду:
                              
vi dpaagent_config.xml                               
#Check the <servername> tag, is this the DPA APP IP address? If it is not then change to the DPA APP IP. Once this is the DPA APP IP save and exit.
                         
./dpa stop
 
    1. Выберите /opt/emc/dpa/agent/data и выполните следующую команду:
                        
mkdir olddata
mv * olddata/

           
    1. Выберите /opt/emc/dpa/agent/etc и выполните следующую команду:
                       
 ./dpa start 

           
    1. Выберите /opt/emc/dpa/agent/bin и выполните следующую команду:
                       
./dpaagent --set-credentials           
#put in the passwork you set in step 2, confirm the password 
           
    1. Выберите /opt/emc/dpa/agent/etc и выполните следующую команду:

                       
 ./dpa start 

           
    1. Выберите /opt/emc/dpa/agent/logs И проверьте dpaagent.log, нет ли ошибок после перезапуска.

 

  1. Снова откройте пользовательский интерфейс DPA и перейдите в раздел Administrator>System>Configure System Settings. Во всплывающем окне нажмите стрелку рядом с пунктом Агенты сбора данных , чтобы развернуть список. Проверьте, не появляется ли агент снова.

Перейдите навкладкуInventory>Object Library> Applications. Выберите Avamar и нажмите кнопку Properties . Во всплывающем окне Properties перейдите на вкладку Data Collection . Выберите коллекции Avamar Job Monitor и нажмите кнопку журнал. Проверьте, был ли последний сбор данных успешным.


Если у вас возникнут какие-либо вопросы, обратитесь в службу поддержки Dell.

Affected Products

Integrated Data Protection Appliance Family

Products

Data Protection Advisor, PowerProtect Data Protection Software
Article Properties
Article Number: 000181653
Article Type: Solution
Last Modified: 02 Dec 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.