Data Domain:已升級外部機櫃韌體的 HA 滾動式升級可能會失敗
Summary: 此知識文章說明已升級外部機櫃韌體的 HA 滾動式升級可能會失敗的問題
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
在升級至 7.5 之前的版本時,在有多個 SAS HBA 連接埠連接至外部機櫃的組態上的 HA 滾動式升級可能會失敗。
Cause
在 7.5 之前的 DDOS 版本中,在第一個節點升級並重新啟動後發生的容錯移轉期間,會執行 HA 組態的機櫃韌體升級程式。
根據拓撲、連接的外部儲存機櫃數量和類型,以及機櫃 FW 的起始和結束版本,完成升級所需的時間可能會超過第二個節點重新開機並嘗試重新加入 HA 配對所需的時間。如果發生這種情況,系統會進入降級的 HA 狀態,且升級程序將會停止。必須手動介入才能修復至良好狀態。
從 DDOS 7.5 開始,只要所有磁碟機和機櫃有 2 個運作的路徑,機櫃韌體升級程序便會在背景中執行。這可讓 HA 容錯移轉在合理的時間內發生。
根據拓撲、連接的外部儲存機櫃數量和類型,以及機櫃 FW 的起始和結束版本,完成升級所需的時間可能會超過第二個節點重新開機並嘗試重新加入 HA 配對所需的時間。如果發生這種情況,系統會進入降級的 HA 狀態,且升級程序將會停止。必須手動介入才能修復至良好狀態。
從 DDOS 7.5 開始,只要所有磁碟機和機櫃有 2 個運作的路徑,機櫃韌體升級程序便會在背景中執行。這可讓 HA 容錯移轉在合理的時間內發生。
Resolution
此問題已在 7.5 及更新版本中解決。
若要升級到 7.5 前,因應措施是:
在 HA 升級之前,請手動檢查目標組建是否需要任何分層架 FW 升級。如果是,請執行本機升級,而非滾動式升級。因應措施的缺點是停機時間比滾動式升級更長 (可能會是一小時以上)。
以下是韌體版本 – 根據版本表:
適用於 DS60、FS25 及 ES40 分層架機型
若為 ES30 分層架機型,則每個版本的韌體版本為 1.55。
如果您有其他未包含在本文件中的分層架機型,請聯絡支援以取得進一步確認。
若要升級到 7.5 前,因應措施是:
在 HA 升級之前,請手動檢查目標組建是否需要任何分層架 FW 升級。如果是,請執行本機升級,而非滾動式升級。因應措施的缺點是停機時間比滾動式升級更長 (可能會是一小時以上)。
以下是韌體版本 – 根據版本表:
適用於 DS60、FS25 及 ES40 分層架機型
| 分層架韌體版本 | DDOS 版本 |
| 2.10.1 | 6.1.2.10 |
| 6.1.2.6 | |
| 6.1.2.20 | |
| 6.1.2.30 | |
| 6.1.2.40 | |
| 6.1.2.50 | |
| 6.1.2.55 | |
| 6.1.2.70 | |
| 6.2.0.5 | |
| 6.2.0.10 | |
| 6.2.0.20 | |
| 6.2.0.30 | |
| 6.2.0.35 | |
| 2.10.0 | 6.1.1.30 |
| 2.40.0 | 6.2.1.0 |
| 6.2.1.30 | |
| 6.2.1.40 | |
| 6.2.1.50 | |
| 7.0.0.7 | |
| 2.41.0 | 7.0.0.9 |
| 7.0.0.20 | |
| 7.1.0.5 | |
| 7.1.0.10 | |
| 7.1.0.20 | |
| 7.1.0.30 | |
| 7.1.0.40 | |
| 2.41.1 | 7.2.0.20 |
| 7.2.0.30 | |
| 7.2.0.50 | |
| 7.2.0.60 | |
| 7.3.0.10 | |
| 7.5.0.10 |
若為 ES30 分層架機型,則每個版本的韌體版本為 1.55。
如果您有其他未包含在本文件中的分層架機型,請聯絡支援以取得進一步確認。
Affected Products
Data DomainProducts
Data Domain, DD OSArticle Properties
Article Number: 000191148
Article Type: Solution
Last Modified: 03 Dec 2025
Version: 7
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.