NMDA:一部のターゲットが見つからない - リストアを中止しています RMAN-06025:リストアするログ スレッド1シーケンス1 lowscnのバックアップ1164241見つからない

Summary: NetWorker:データベースのOracleアーカイブ ログのリストアがRMAN-06025で失敗します。リストアする文字列のシーケンス番号と開始SCNを持つスレッド番号のアーカイブ ログのバックアップが見つかりません。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

RMANコマンド「RESTORE ARCHIVELOG ALL VALIDATE」がエラーで
失敗する:RMAN-06025:シーケンス番号を持つスレッド番号のアーカイブ ログのバックアップがなく、リストアする文字列の開始SCNが見つかりました。
 
RMAN-00571: ===========================================================
RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
RMAN-00571: ===========================================================
RMAN-03002: failure of restore command at 12/04/2021 17:33:02
RMAN-06026: some targets not found - aborting restore
RMAN-06025: no backup of log thread 1 seq 1 lowscn 1164241 found to restore

Cause

1.NetWorker管理コンソール ウィザードでは、NMDA Oracleのバックアップ/リカバリ操作を実行できますが、Oracle RAC環境でこれらの操作を実行することはできません。

2.この状況では、デスティネーション ホストがスタンドアロン マシンであっても、ソース コンピューターはOracle RAC構成の一部であり、ウィザードでは移動できません。

3.  この問題は、カタログ データベースを使用していない場合、またはカタログ接続が使用されていない場合に発生します。

4.「RESTORE ARCHIVELOG ALL VALIDATE」ステートメントの「ALL」キーワードでは、バックアップ保存ポリシーは考慮されませんが、RMANリポジトリで参照されているすべてのアーカイブREDOログへのアクセスが試行されます。

Resolution

アクション プラン:

🟆 リカバリー ウィザードは、クラスターまたはOracle RACシステムをサポートしていません。  このような環境でOracleリストアを実行するには、RMANコマンド ライン インターフェイスを使用します。 

次に、次のいずれかのオプションを確認して続行してみてください:-

オプションA:

🟆 controlfileのみを使用すると、カタログデータベースは使用されません。

🟆 RMANコマンド プロンプトから次の構文を使用して、アーカイブ ログ バックアップを検証します。
 
 
1) RMAN> restore archivelog from time='<RECOVERY WINDOWS DAYS#>' validate;
 
リカバリー ウィンドウを7日間に設定した場合は、次のコマンドを使用します。
 
 
2)RMAN>は保存ポリシーを表示します。

RMAN構成パラメーターは次のとおりです。
保存ポリシーを7日間のリカバリー ウィンドウに設定します。

3)RMAN>リストア アーカイブ ログfrom time = 'SYSDATE-7'検証。

12
年1月13日にリストアを開始 チャネルORA_DISK_1

チャネルORA_DISK_1の使用:アーカイブ ログ バックアップセット
の検証の開始 チャネル ORA_DISK_1:バックアップ ピース <パス>\BACKUPSET\2012_01_13\O1_MF_ANNNN_TAG20120113T111853_7JZKG717_から読み取ります。BKP
チャネルORA_DISK_1:リストアされたバックアップピース1
ピースのハンドル=<path>\BACKUPSET\2012_01_13\O1_MF_ANNNN_TAG20120113T111853_7JZKG717_。BKP タグ = TAG20120113T111853
チャネルORA_DISK_1: 検証が完了し、経過時間:     00:00:02
チャネルORA_DISK_1:アーカイブ ログ バックアップセット
の検証を開始しています チャネルORA_DISK_1:バックアップ ピース <パス>\BACKUPSET\2012_01_13\O1_MF_ANNNN_TAG20120113T112054_7JZKL018_から読み取り中です。BKP
チャネルORA_DISK_1:リストアされたバックアップピース1
ピースのハンドル=<path>\BACKUPSET\2012_01_13\O1_MF_ANNNN_TAG20120113T112054_7JZKL018_。BKPタグ=TAG20120113T112054
チャネルORA_DISK_1:検証完了、経過時間: 00:00:03
12年1月13日にリストアを完了
RMAN>


オプションB:

🟆 リカバリー カタログが構成されている場合は、ターゲット データベースとリカバリー カタログに接続すると、「RESTORE ARCHIVELOG ALL VALIDATE;」がエラーなしで機能します。

   
 
🟆 RMANターゲット/カタログ <ユーザー名>/<パスワード>@<catalog_tns>
 
Recovery Manager: リリース10.2.0.4.0 - 2012
 
年1月13日(金)11:37:11に生産 Copyright (c) 1982, 2007, Oracle.All rights reserved.

ターゲットデータベースに接続: dbname> (DBID=<dbid>)
リカバリカタログデータベース

に接続🟆 RMAN> RESTORE ARCHIVELOG ALL VALIDATE;

<13-JAN-12
にリストアを開始 割り当てられたチャネル:  
ORA_DISK_1 チャネル ORA_DISK_1:sid=35 devtype=DISK

チャネルORA_DISK_1:アーカイブ ログ バックアップセット
の検証の開始 チャネル ORA_DISK_1:バックアップ ピース <パス>\BACKUPSET\2012_01_13\O1_MF_ANNNN_TAG20120113T111853_7JZKG717_から読み取り中。BKP
チャネルORA_DISK_1:リストアされたバックアップピース1
ピースのハンドル=<path>\BACKUPSET\2012_01_13\O1_MF_ANNNN_TAG20120113T111853_7JZKG717_。BKPタグ=TAG20120113T111853
チャネルORA_DISK_1:検証完了、経過時間:  00:00:02
チャネルORA_DISK_1:アーカイブ ログ バックアップセット
の検証を開始していますチャネル ORA_DISK_1:バックアップ ピースv\BACKUPSET\2012_01_13\O1_MF_ANNNN_TAG20120113T112054_7JZKL018_から読み取り中です。BKP
チャネルORA_DISK_1:リストアされたバックアップ ピース1
ピースのハンドル=<path>\BACKUPSET\2012_01_13\O1_MF_ANNNN_TAG20120113T112054_7JZKL018_。BKPタグ=TAG20120113T112054
チャネルORA_DISK_1:検証完了、経過時間: 00:00:03
12年1月

 
13日のRMANにリストアを完了>

Additional Information

 
処置:なし - これは情報メッセージです。詳細については、メッセージ 6026 を参照してください。


2021

年12月4日にリストアを開始リリース済みチャネル: t0 リリース済みチャネル: t1

リリース済みチャネル: t2
リリース済みチャネル: t3
RMAN-00571: ===========================================================
RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
RMAN-00571: ===========================================================
RMAN-03002:2021/12/04 17:33:02
RMAN-06026:一部のターゲットが見つからない - リストア
を中止する RMAN-06025:シーケンス447871およびstar
のスレッド2のアーカイブ ログのバックアップがない RMAN-06025:シーケンス447870およびstar
のスレッド2のアーカイブ ログのバックアップがない RMAN-06025:シーケンス447869とstar
のスレッド2のアーカイブ ログのバックアップがないRMAN-06025:シーケンス447868とstar
のスレッド2のアーカイブ ログのバックアップがない RMAN-06025:シーケンス447867とstar
のスレッド2のアーカイブ ログのバックアップがない RMAN-06025:シーケンス447866とstar
のスレッド2のアーカイブ ログのバックアップがない RMAN-06025:シーケンス447865とstar
のスレッド2のアーカイブ ログのバックアップがない RMAN-06025: シーケンス 447864 と star のスレッド 2 のアーカイブ ログのバックアップがない RMAN-06025: シーケンス 447863 と star
のスレッド 2 のアーカイブ ログのバックアップがない RMAN-06025: シーケンス 447862 と star
のスレッド 2 のアーカイブ ログのバックアップがない RMAN-06025: シーケンス 447861 と star

のスレッド 2 のアーカイブ ログのバックアップがない RMAN-06025: シーケンス447860およびstarのスレッド2のアーカイブ ログのバックアップがない


 





Affected Products

NetWorker Family
Article Properties
Article Number: 000197393
Article Type: Solution
Last Modified: 05 Jun 2023
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.