NetWorker: Soubor restapi.log není vygenerován na serveru NetWorker nasazeném v clusteru Red Hat Pacemaker.
Summary: Soubory restapi.log se negenerují na serveru NetWorker nasazeném v clusteru Red Hat Pacemaker.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
- Server NetWorker je nasazen v clusteru Red Hat HA (kardiostimulátor).
- Protokoly rozhraní API (Application Programming Interface) rozhraní REST (Application Programming Interface) v umístění /nsr/logs/restapi protokoly se negenerují.
Cause
Sdílená jednotka není mapována na protokolování rozhraní REST API.
Resolution
- Přihlaste se k aktivnímu uzlu jako uživatel root.
Aktivní uzel lze zobrazit pomocí:
pcs resource show
Příklad:
root@NWrhelNodeC:~# pcs resource show
Resource Group: NW_group
fs (ocf::heartbeat:Filesystem): Started NWrhelNodeC.emclab.local
ip (ocf::heartbeat:IPaddr): Started NWrhelNodeC.emclab.local
nws (ocf::EMC_NetWorker:Server): Started NWrhelNodeC.emclab.local
- Potvrďte mapování používané kardiostimulátorem:
lcmap
Příklad:
root@NWrhelNodeC:~# lcmap
type: NSR_CLU_TYPE;
clu_type: NSR_LC_TYPE;
interface version: 1.0;
type: NSR_CLU_VIRTHOST;
hostname: 192.168.25.40;
local: TRUE;
owned paths: /nsr_share;
- Vytvořte kopii logback.xml rozhraní REST API:
cp /nsr/authc/webapps/nwrestapi/WEB-INF/classes/logback.xml /nsr/authc/webapps/nwrestapi/WEB-INF/classes/logback.xml.bak
- Upravte logback.xml tak, aby používal absolutní cestu k adresáři protokolů rozhraní REST API:
vi /nsr_share/nsr/authc/webapps/nwrestapi/WEB-INF/classes/logback.xml
Vyměnit:
<?xml version="1.0" encoding="UTF-8"?>
<configuration scan="true" scanPeriod="10 seconds">
<contextListener class="ch.qos.logback.classic.jul.LevelChangePropagator">
<resetJUL>true</resetJUL>
</contextListener>
<define name="logdir" class="com.emc.nw.webapi.LogDir"/>
<appender name="file" class="ch.qos.logback.core.rolling.RollingFileAppender">
<file>${logdir}/restapi.log</file>
<encoder>
<pattern>%d{yyyy-MM-dd HH:mm:ss.SSS} %-5level [%thread] %logger{15} - %msg%n</pattern>
</encoder>
<rollingPolicy class="ch.qos.logback.core.rolling.FixedWindowRollingPolicy">
<fileNamePattern>${logdir}/restapi_%i.log.zip</fileNamePattern>
<minIndex>1</minIndex>
<maxIndex>10</maxIndex>
<totalSizeCap>500MB</totalSizeCap>
...
Komu:
<?xml version="1.0" encoding="UTF-8"?>
<configuration scan="true" scanPeriod="10 seconds">
<contextListener class="ch.qos.logback.classic.jul.LevelChangePropagator">
<resetJUL>true</resetJUL>
</contextListener>
<define name="logdir" class="com.emc.nw.webapi.LogDir"/>
<appender name="file" class="ch.qos.logback.core.rolling.RollingFileAppender">
<file>/nsr_share/nsr/logs/restapi/restapi.log</file>
<encoder>
<pattern>%d{yyyy-MM-dd HH:mm:ss.SSS} %-5level [%thread] %logger{15} - %msg%n</pattern>
</encoder>
<rollingPolicy class="ch.qos.logback.core.rolling.FixedWindowRollingPolicy">
<fileNamePattern>/nsr_share/nsr/logs/restapi/restapi_%i.log.zip</fileNamePattern>
<minIndex>1</minIndex>
<maxIndex>10</maxIndex>
<totalSizeCap>500MB</totalSizeCap>
...
POZNÁMKA: Ujistěte se, že název sdílené cesty odpovídá názvu sdílené složky vydané příkazem lcmap .
- Ruční vytvoření složky logs
mkdir /nsr_share/nsr/logs/restapi
- Změňte vlastnictví adresáře na nsrtomcat:
chown nsrtomcat:nsrtomcat /nsr_share/nsr/logs/restapi
- Nastavte oprávnění k adresáři rozhraní REST API:
chmod 755 /nsr_share/nsr/logs/restapi
- Restartujte clusterované služby NetWorker:
pcs resource restart nws
- Ověřte, že se po spuštění prostředku nws generuje soubor restapi.log:
root@NWrhelNodeC:~# ls -l /nsr_share/nsr/logs/restapi/ total 7428 -rw-------. 1 nsrtomcat nsrtomcat 7603829 Dec 14 11:01 restapi.log -rw-------. 1 nsrtomcat nsrtomcat 0 Dec 14 10:46 rest_index.raw
Additional Information
Affected Products
NetWorkerProducts
NetWorker Family, NetWorker SeriesArticle Properties
Article Number: 000206436
Article Type: Solution
Last Modified: 24 Mar 2025
Version: 3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.