NetWorker: Red Hat pacemaker kümesinde dağıtılan NetWorker sunucusunda restapi.log dosyası oluşturulmadı
Summary: restapi.log dosyaları, Red Hat pacemaker kümesinde dağıtılan bir NetWorker sunucusunda oluşturulmaz.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
- NetWorker sunucusu bir Red Hat HA (kalp pili) kümesine dağıtılır.
- /nsr/logs/restapi günlükleri altındaki Temsili Durum Aktarımı (REST) Uygulama Programlama Arayüzü (API) günlükleri oluşturulmuyor.
Cause
Ortak drive, REST API günlüğüyle eşlenmiyor.
Resolution
- Aktif düğümde kök olarak oturum açın.
Aktif düğüm aşağıdakilerle gösterilebilir:
pcs resource show
Example:
root@NWrhelNodeC:~# pcs resource show
Resource Group: NW_group
fs (ocf::heartbeat:Filesystem): Started NWrhelNodeC.emclab.local
ip (ocf::heartbeat:IPaddr): Started NWrhelNodeC.emclab.local
nws (ocf::EMC_NetWorker:Server): Started NWrhelNodeC.emclab.local
- Pacemaker tarafından kullanılan eşlemeyi onaylayın:
lcmap
Example:
root@NWrhelNodeC:~# lcmap
type: NSR_CLU_TYPE;
clu_type: NSR_LC_TYPE;
interface version: 1.0;
type: NSR_CLU_VIRTHOST;
hostname: 192.168.25.40;
local: TRUE;
owned paths: /nsr_share;
- REST API'nin bir kopyasını oluşturun logback.xml:
cp /nsr/authc/webapps/nwrestapi/WEB-INF/classes/logback.xml /nsr/authc/webapps/nwrestapi/WEB-INF/classes/logback.xml.bak
- REST API günlük dizininin mutlak yolunu kullanmak için logback.xml değiştirin:
vi /nsr_share/nsr/authc/webapps/nwrestapi/WEB-INF/classes/logback.xml
Değiştirmek:
<?xml version="1.0" encoding="UTF-8"?>
<configuration scan="true" scanPeriod="10 seconds">
<contextListener class="ch.qos.logback.classic.jul.LevelChangePropagator">
<resetJUL>true</resetJUL>
</contextListener>
<define name="logdir" class="com.emc.nw.webapi.LogDir"/>
<appender name="file" class="ch.qos.logback.core.rolling.RollingFileAppender">
<file>${logdir}/restapi.log</file>
<encoder>
<pattern>%d{yyyy-MM-dd HH:mm:ss.SSS} %-5level [%thread] %logger{15} - %msg%n</pattern>
</encoder>
<rollingPolicy class="ch.qos.logback.core.rolling.FixedWindowRollingPolicy">
<fileNamePattern>${logdir}/restapi_%i.log.zip</fileNamePattern>
<minIndex>1</minIndex>
<maxIndex>10</maxIndex>
<totalSizeCap>500MB</totalSizeCap>
...
Şu şekilde değiştirin:
<?xml version="1.0" encoding="UTF-8"?>
<configuration scan="true" scanPeriod="10 seconds">
<contextListener class="ch.qos.logback.classic.jul.LevelChangePropagator">
<resetJUL>true</resetJUL>
</contextListener>
<define name="logdir" class="com.emc.nw.webapi.LogDir"/>
<appender name="file" class="ch.qos.logback.core.rolling.RollingFileAppender">
<file>/nsr_share/nsr/logs/restapi/restapi.log</file>
<encoder>
<pattern>%d{yyyy-MM-dd HH:mm:ss.SSS} %-5level [%thread] %logger{15} - %msg%n</pattern>
</encoder>
<rollingPolicy class="ch.qos.logback.core.rolling.FixedWindowRollingPolicy">
<fileNamePattern>/nsr_share/nsr/logs/restapi/restapi_%i.log.zip</fileNamePattern>
<minIndex>1</minIndex>
<maxIndex>10</maxIndex>
<totalSizeCap>500MB</totalSizeCap>
...
NOT: Paylaşım yolu adının, lcmap komutu tarafından oluşturulan paylaşılan klasörün adıyla eşleştiğinden emin olun.
- Günlükler klasörünü manuel olarak oluşturma
mkdir /nsr_share/nsr/logs/restapi
- Dizinin sahipliğini nsrtomcat olarak değiştirin:
chown nsrtomcat:nsrtomcat /nsr_share/nsr/logs/restapi
- REST API dizininde izinleri ayarlayın:
chmod 755 /nsr_share/nsr/logs/restapi
- Kümelenmiş NetWorker hizmetlerini yeniden başlatın:
pcs resource restart nws
- nws kaynağı başlatıldıktan sonra restapi.log dosyasının oluşturulmakta olduğunu doğrulayın:
root@NWrhelNodeC:~# ls -l /nsr_share/nsr/logs/restapi/ total 7428 -rw-------. 1 nsrtomcat nsrtomcat 7603829 Dec 14 11:01 restapi.log -rw-------. 1 nsrtomcat nsrtomcat 0 Dec 14 10:46 rest_index.raw
Additional Information
Affected Products
NetWorkerProducts
NetWorker Family, NetWorker SeriesArticle Properties
Article Number: 000206436
Article Type: Solution
Last Modified: 24 Mar 2025
Version: 3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.