Dell VxRail 14G Nodes: Upgrade from an active TPM 1.2 module to a TPM 2.0 module without temporarily disabling the module
Summary: This article guides you through handling an active TPM 1.2 module by upgrading from an active TPM 1.2 module to a TPM 2.0 module without temporarily disabling the active TPM 1.2 module. Reimaging the nodes through a professional service engagement will be required as part of this procedure. ...
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Symptoms
This article guides you through handling an active TPM 1.2 module by upgrading from an active TPM 1.2 module to a TPM 2.0 module without temporarily disabling the active TPM 1.2 module.
Because we are not temporarily disabling the active TPM 1.2 module, reimaging the nodes through a professional service engagement will be required as part of this procedure.
Because we are not temporarily disabling the active TPM 1.2 module, reimaging the nodes through a professional service engagement will be required as part of this procedure.
Cause
This article is one method for dealing with Article 000204703.
Article 000204703 is about VxRail Clusters with 14G nodes that have an active TPM 1.2 module failing the LCM precheck with the error message "VxRail Update ran into a problem".
If you would rather not reimage, see Article 000207726 for an alternate method of handling active TPM 1.2 modules.
Article 000204703 is about VxRail Clusters with 14G nodes that have an active TPM 1.2 module failing the LCM precheck with the error message "VxRail Update ran into a problem".
If you would rather not reimage, see Article 000207726 for an alternate method of handling active TPM 1.2 modules.
Resolution
Prerequisites:
- You need to procure (contact Dell Sales) a TPM 2.0 Module for every node you want to upgrade.
- The TPM 1.2 Modules in the current nodes needs to be functioning (no hardware errors).
- Confirm in the vCenter Managed Object Browser (MOB) that the TPM Version is 1.2
a. Go to https://<vcenter_ip>/mob and browse to your VMware vCenter’s Managed Object Browser (MOB).
b. When prompted for a username and password enter the same credentials you would use to access your vCenter Web Client. Please ensure this account has administrator access.
c. Select the active link in the value column for each of the following items: content > rootFolder > childEntity > hostFolder > childEntity.
d. This page will display a host value. The Managed Object ID (MOID) for each host displays next to host. In the example below they are highlighted in yellow.
e. Complete the following steps for each node in the cluster:
b. When prompted for a username and password enter the same credentials you would use to access your vCenter Web Client. Please ensure this account has administrator access.
c. Select the active link in the value column for each of the following items: content > rootFolder > childEntity > hostFolder > childEntity.
d. This page will display a host value. The Managed Object ID (MOID) for each host displays next to host. In the example below they are highlighted in yellow.
e. Complete the following steps for each node in the cluster:
i. Browse to https://<vcenter_ip>/mob/?moid=<Node_MOID>&doPath=capability
ii. Check the tpmVersion on this page
ii. Check the tpmVersion on this page
- If the value is Unset, the TPM Module is disabled on the host. This KB is not required.
- If the value is 2.0, the TPM Module is active and at a supported version for vSphere 8.0. This KB is not required.
- If the value is 1.2, the TPM Module is active. If you do not want to temporarily turn off this module, continue to the next step of this KB.
- Verify that the vSAN cluster is in a healthy state.
Log into your vCenter and navigate to VxRail Cluster > Monitor > vSAN > Skyline Health and ensure the vSAN is healthy. If there are any errors or warnings, please resolve them before continuing. The only exception to this would be if you are using a system that is not connected to the Internet and the errors are related to Internet access.
Resolution Steps:
This will require reimaging of your nodes as part of the upgrade. Contact Dell Technical Support or your Authorized Service Representative for assistance.
Article Properties
Article Number: 000207727
Article Type: Solution
Last Modified: 13 Sept 2023
Version: 6
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