PowerProtect: Cyber Recovery Docker containers fail to start "Cannot connect to the Docker daemon"

Summary: Customer is unable to use Cyber Recovery due to docker containers unable to start because of the docker daemon not running.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

when trying to run docker ps a message appears asking if the docker daemon is running.
 
[root@hostname ~]# docker ps -a
Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon running?


the docker service is not active
 
[root@hostname ~]# systemctl status docker
? docker.service - Docker Application Container Engine
   Loaded: loaded (/usr/lib/systemd/system/docker.service; enabled; vendor preset: disabled)
   Active: failed (Result: start-limit) since Wed 2022-11-16 07:39:05 EST; 3min 34s ago
     Docs: https://docs.docker.com
 Main PID: 7590 (code=exited, status=1/FAILURE)

Nov 16 07:39:02 hostname systemd[1]: docker.service failed.
Nov 16 07:39:05 hostname systemd[1]: docker.service holdoff time over, scheduling restart.
Nov 16 07:39:05 hostname systemd[1]: Stopped Docker Application Container Engine.
Nov 16 07:39:05 hostname systemd[1]: start request repeated too quickly for docker.service
Nov 16 07:39:05 hostname systemd[1]: Failed to start Docker Application Container Engine.
Nov 16 07:39:05 hostname systemd[1]: Unit docker.service entered failed state.
Nov 16 07:39:05 hostname systemd[1]: docker.service failed.
Nov 16 07:39:40 hostname systemd[1]: start request repeated too quickly for docker.service
Nov 16 07:39:40 hostname systemd[1]: Failed to start Docker Application Container Engine.
Nov 16 07:39:40 hostname systemd[1]: docker.service failed.


Cause

when trying to start the docker daemon there is message warning of a space issue
 
[root@ hostname]# sudo dockerd
Error starting daemon: Unable to get the TempDir under /var/lib/docker: mkdir /var/lib/docker/tmp: no space left on device

there was a disk space issue. The root filesystem appears to be full:
 
[root@hostname ~]# df -kh
Filesystem                                Size  Used Avail Use% Mounted on
/dev/mapper/centos_hostname-root   38G   38G   20K 100% /        <<<<
devtmpfs                                  1.9G     0  1.9G   0% /dev
tmpfs                                     1.9G  8.0K  1.9G   1% /dev/shm
tmpfs                                     1.9G  8.9M  1.9G   1% /run
tmpfs                                     1.9G     0  1.9G   0% /sys/fs/cgroup
/dev/sda1                                1014M  189M  826M  19% /boot
/dev/mapper/centos_ehs--hostname-home   19G  3.0G   16G  17% /home
tmpfs                                     379M     0  379M   0% /run/user/0
[root@hostname ~]#



Resolution

After claiming some space by removing some old support bundles and packages for previous releases that are no longer needed, and then rebooted the Cyber Recovery VM. the containers were now running again and customer was able to resume using cyber recovery.

Affected Products

Cyber Recovery Series

Products

Cyber Recovery Series, CyberSense
Article Properties
Article Number: 000214296
Article Type: Solution
Last Modified: 04 Nov 2025
Version:  2
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