PowerScale: NFS kann nach dem Neustart des Clusters zeitweise keinen Export einfügen, was zu einem Client-Mount-Fehler führt
Summary: NFS (Network File System) kann nach dem Upgrade oder Neustart keine Exporte einfügen, was dazu führt, dass der NFS-Client NFS-Freigaben mit dem Fehler "No such file or directory" nicht mounten kann. ...
Symptoms
Clients, die versuchen, einen zuvor verwendeten Export zu mounten oder einen Vorgang für einen zuvor verwendeten Export durchzuführen, erhalten diesen Fehler:
# mount -F nfs example.com:/ifs/testexport /tmp nfs mount: example.com:/ifs/testexport: No such file or directory # cd /test -bash: cd: /test: No such file or directory
Die folgenden Meldungen werden möglicherweise im nfs.log. Aliase können den Export nicht einfügen, da die Pfadeinträge nicht unter der LIN-Struktur vorhanden sind:
TESTCLUSTER-21 nfs[4900]: [nfs] Failed to insert "/ifs/testexport" for export 36 with status 0xc0000467(STATUS_FILE_NOT_AVAILABLE) TESTCLUSTER-21 nfs[4900]: [nfs] Problem inserting alias /testexport 0xc0000467 (STATUS_FILE_NOT_AVAILABLE)
Cause
Die Wahrscheinlichkeit, dass dieses Problem auftritt, ist relativ gering, aber es wurde beobachtet, wenn Cluster gleichzeitig neu gestartet wurden (Upgrade, Patchinstallation usw.). Während des NFS-Starts wird ein syscall ausgegeben, um den Export zu öffnen und zu laden. Es kann in seltenen Fällen vorkommen, dass der Systemaufruf aufgrund des gleichzeitigen Neustarts fehlschlägt, was dazu führt, dass ein oder mehrere Exporte nicht geladen werden.
Resolution
Eine mögliche Problemumgehung besteht darin, einen fortlaufenden Neustart anstelle eines gleichzeitigen Neustarts auszuführen. Führen Sie beispielsweise anstelle eines simultanen Upgrades ein sequenzielles Upgrade durch.
Um dieses Problem zu beheben, laden Sie die betroffenen Zonen neu. Dies sollte unterbrechungsfrei sein.
isi nfs exports reload --zone=<zone of affected exports>
Wenn der obige Befehl keine Lösung bietet, wenden Sie sich an den Dell PowerScale-Support , um das Problem zu beheben.
Dieses Problem wird in den folgenden Versionen behoben:
- OneFS 9.2.1.25 und höher
- OneFS 9.4.0.16 und höher
- OneFS 9.5.0.7 und höher