PowerScale. После перезагрузки кластера NFS периодически не удается вставить экспорт, что приводит к сбою монтирования клиента

Summary: Сетевой файловой системе (NFS) не удается вставить экспортируемые каталоги после модернизации или перезагрузки, что приводит к тому, что клиенту NFS не удается смонтировать общие ресурсы NFS с ошибкой «No such file or directory». ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Клиенты, пытающиеся смонтировать или выполнить операцию с ранее использовавшимся экспортом, получают следующую ошибку:

# mount -F nfs example.com:/ifs/testexport /tmp
nfs mount: example.com:/ifs/testexport: No such file or directory

# cd /test
-bash: cd: /test: No such file or directory

В меню могут отображаться следующие сообщения nfs.log. Псевдонимы не удается вставить экспорт, так как записи пути отсутствуют в дереве LIN:

TESTCLUSTER-21 nfs[4900]: [nfs] Failed to insert "/ifs/testexport" for export 36 with status 0xc0000467(STATUS_FILE_NOT_AVAILABLE)

TESTCLUSTER-21 nfs[4900]: [nfs] Problem inserting alias /testexport 0xc0000467 (STATUS_FILE_NOT_AVAILABLE)

Cause

Вероятность возникновения этой проблемы относительно невелика, однако она наблюдается при одновременной перезагрузке кластеров (обновлении, установке исправлений и т. д.). Во время запуска NFS инициируется системный вызов для открытия и загрузки экспорта. Существует крайне низкая вероятность того, что системный вызов может завершиться сбоем из-за одновременной перезагрузки, что приведет к сбою загрузки одного или нескольких экспортов.

Resolution

Возможное временное решение проблемы — выполнять последовательную перезагрузку вместо одновременной перезагрузки. Например, вместо одновременного обновления запустите последовательное обновление.

Чтобы решить эту проблему, перезагрузите затронутые зоны. Это не должно приводить к прерыванию работы.

isi nfs exports reload --zone=<zone of affected exports>

Если указанная выше команда не помогла устранить проблему, обратитесь в службу поддержки Dell PowerScale для устранения проблемы.

Эта проблема устранена в следующих версиях: 

  • OneFS 9.2.1.25 и более поздние версии
  • OneFS 9.4.0.16 и более поздние версии
  • OneFS 9.5.0.7 и более поздние версии

Affected Products

PowerScale OneFS
Article Properties
Article Number: 000220266
Article Type: Solution
Last Modified: 16 Dec 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.