PowerScale: NFS kan af en toe geen export invoegen na opnieuw opstarten van cluster, wat leidt tot een fout bij het koppelen van de client

Summary: Network File System (NFS) kan geen exports invoegen na een upgrade of herstart, wat ertoe leidt dat de NFS-client NFS-shares niet kan koppelen met de foutmelding No such file or directory. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Clients die proberen een bewerking te koppelen of uit te voeren op een eerder gebruikte export, ontvangen deze foutmelding:

# mount -F nfs example.com:/ifs/testexport /tmp
nfs mount: example.com:/ifs/testexport: No such file or directory

# cd /test
-bash: cd: /test: No such file or directory

De volgende berichten zijn te zien in de nfs.log. Aliassen kunnen de export niet invoegen omdat de padvermeldingen niet aanwezig zijn onder de LIN-structuur:

TESTCLUSTER-21 nfs[4900]: [nfs] Failed to insert "/ifs/testexport" for export 36 with status 0xc0000467(STATUS_FILE_NOT_AVAILABLE)

TESTCLUSTER-21 nfs[4900]: [nfs] Problem inserting alias /testexport 0xc0000467 (STATUS_FILE_NOT_AVAILABLE)

Cause

Er is een relatief kleine kans om met dit probleem te maken te krijgen, maar het is waargenomen wanneer clusters tegelijkertijd opnieuw opstarten (upgrade, patchinstallatie, enzovoort). Tijdens het starten van NFS wordt een syscall uitgegeven om de export te openen en te laden. Er is een zeldzame kans dat de syscall mislukt als gevolg van het gelijktijdig opnieuw opstarten, waardoor het laden van een of meer exports mislukt.

Resolution

Een mogelijke tijdelijke oplossing is om een rollende herstart uit te voeren in plaats van gelijktijdig opnieuw op te starten. Voer bijvoorbeeld in plaats van een gelijktijdige upgrade een doorlopende upgrade uit.

Om dit probleem op te lossen, laadt u de getroffen zones opnieuw. Dit mag niet storend zijn.

isi nfs exports reload --zone=<zone of affected exports>

Als de bovenstaande opdracht geen verlichting biedt, neemt u contact op met Dell PowerScale Support om het probleem op te lossen.

Dit probleem wordt opgelost in de volgende versies: 

  • OneFS 9.2.1.25 en hoger
  • OneFS 9.4.0.16 en hoger
  • OneFS 9.5.0.7 en hoger

Affected Products

PowerScale OneFS
Article Properties
Article Number: 000220266
Article Type: Solution
Last Modified: 16 Dec 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.