PowerScale OneFS: Při upgradu z verze před OneFS 9.5 na 9.5 je protokol LDAP offline na všech uzlech

Summary: Při upgradu ze systému OneFS 9.4 nebo staršího na OneFS 9.5 se může protokol LDAP (Lightweight Directory Access Protocol) zobrazit offline a účet použitý pro BIND se může zobrazit jako uzamčený. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Při upgradu ze systému OneFS 9.4 nebo staršího na OneFS 9.5 se může stát, že se protokol LDAP zobrazí offline u všech uzlů.

 Zprávy podobné těm následujícím se zobrazují v /var/log/lsassd.log Na daném uzlu: 

ClusterName-2(id2) lsass[6461]: [lsass] Failed to bind to LDAP server as 'BindAccount', [Error 49, Invalid credentials] 

ClusterName-2(id2) lsass[6461]: [lsass] Failed connect to ldap server: ldap://LDAPFQDN. Error code: 40330 (symbol: LW_ERROR_LDAP_INVALID_CREDENTIALS). Marking server as denylist.

Při kontrole na straně LDAP se účet použitý pro BIND zobrazuje jako uzamčený kvůli příliš velkému počtu neúspěšných pokusů o zadání hesla. 

Cause

V systému OneFS 9.5 se heslo používané pro BIND je přesunut z gconfig ke správci klíčů. Služba LSASS však může dokončit načítání před dokončením migrace, což vede k NULL uchovávané po dobu BindPW ve Správci klíčů. Cluster se poté pokusí BIND k serveru LDAP pomocí příkazu NULL heslo.
 

Resolution

Odemknutí účtu na straně LDAP, který se používá pro BIND, obnoví přístup. Tento problém by neměl mít vliv na žádné budoucí upgrady kódu, protože heslo se po aktualizaci služby lsass úspěšně přečte ze správce klíčů. 

Upgrade na některou z následujících verzí systému OneFS by měl tomuto problému předejít, protože pokud se čtení z nástroje Key Manager nezdaří, došlo k navrácení služeb po obnovení:

  • OneFS 9.5.1.0
  • OneFS 9.7.1.1
  • OneFS 9.8.0.1
Article Properties
Article Number: 000223334
Article Type: Solution
Last Modified: 16 Dec 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.