PowerScale OneFS: LDAP offline-tilassa kaikissa solmuissa, kun päivität OneFS 9.5:stä versioon 9.5

Summary: Kun päivität OneFS 9.4:stä tai aiemmasta OneFS 9.5:een, LDAP (Lightweight Directory Access Protocol) saattaa näkyä offline-tilassa ja BIND:hen käytetty tili lukittuna.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Kun päivität OneFS 9.4:stä tai aiemmasta OneFS 9.5:een, LDAP saattaa näkyä offline-tilassa kaikissa solmuissa.

 Seuraavankaltaisia viestejä näkyy kohdassa /var/log/lsassd.log Tietyssä solmussa: 

ClusterName-2(id2) lsass[6461]: [lsass] Failed to bind to LDAP server as 'BindAccount', [Error 49, Invalid credentials] 

ClusterName-2(id2) lsass[6461]: [lsass] Failed connect to ldap server: ldap://LDAPFQDN. Error code: 40330 (symbol: LW_ERROR_LDAP_INVALID_CREDENTIALS). Marking server as denylist.

Kun tarkistetaan LDAP-puolella, BIND: ssä käytetty tili näkyy lukittuna liian monen epäonnistuneen salasanayrityksen vuoksi. 

Cause

OneFS 9.5:ssä salasana, jota käytetään BIND on siirretty kohteesta gconfig avainpäällikölle. LSASS saattaa kuitenkin lopettaa latauksen ennen siirron päättymistä, mikä johtaa NULL varastoidaan BindPW avainhallinnassa. Tämän jälkeen klusteri yrittää BIND LDAP-palvelimeen käyttämällä NULL Salasana.
 

Resolution

BIND-tunnuksena käytettävän tilin lukituksen avaaminen LDAP-puolella palauttaa pääsyn. Tämän ongelman ei pitäisi vaikuttaa tuleviin koodipäivityksiin, koska salasana luetaan avaintenhallinnasta onnistuneesti, kun lsass on päivitetty. 

Ongelma on tarkoitus välttää päivittämällä johonkin seuraavista OneFS-versioista, sillä käyttöön tulee vikasietoisuus, jos avainten hallinta ei onnistu:

  • OneFS 9.5.1.0
  • OneFS 9.7.1.1
  • OneFS 9.8.0.1
Article Properties
Article Number: 000223334
Article Type: Solution
Last Modified: 16 Dec 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.