PowerStore: Překrývající se vstupně-výstupní operace na svazku Metro mohou vést k neočekávanému restartování nebo zvýšení latence

Summary: Překrývající se vstupně-výstupní operace na svazku Metro mohou vést k neočekávanému restartování uzlu nebo vyšší latenci.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Uzel se může neočekávaně restartovat nebo může dojít ke zvýšené latenci, pokud jsou splněny všechny tyto podmínky:

  • PowerStoreOS 3.6.1.0
  • Svazky metra
  • Hostitelé ESXi nakonfigurovaní s přístupem nastaveným jako společně umístění s oběma systémy
  • K problému může dojít také během upgradů bez rušení z verze 3.6.1, pokud je implementováno níže popsané zástupné řešení.

Cause

V systému PowerStoreOS 3.6.1 byl zaveden problém softwaru, který se týká zařízení s hostiteli nakonfigurovanými jako společně umístění pouze s oběma systémy.
Kvůli problému se softwarem mohou všechny překrývající se vstupy/výstupy přicházející do obou zařízení na stejném svazku na stejné adrese LBA (Logical Block Address) vést k neočekávanému restartování modulu nebo restartování uzlu. Neočekávané restartování softwarového modulu nebo restartování uzlu se může opakovat, dokud se nepoužije oprava nebo zástupné řešení.

Resolution

Oprava

Tento problém je vyřešen ve verzi PowerStoreOS 3.6.1.1 (3.6 Service Pack 1 Patch 1) a vyšší.

 

Poznámka:

Při provádění NDU pozastavte všechny relace Metro před upgradem z verze 3.6.1 (pouze) na jakoukoli budoucí verzi a obnovte replikaci po dokončení NDU.

  • Před upgradem z verze 3.6.1 na jakoukoli budoucí verzi pozastavte všechny relace Metro.

Alternativně:

  • Nekonfigurujte svazek Metro jako "Metro_Optimized_Local" na neupřednostňovaném zařízení, dokud se upgrade bez rušení nedokončí.
  • Pokud místní zařízení není upřednostňováno pro všechny relace Metro v tomto zařízení (Protection –> Metro –> Local Preferred Role), ujistěte se, že je libovolný hostitel připojený ke svazku Metro nakonfigurován jako Metro_Optimized_Remote, dokud se nedokončí upgrade bez rušení.
  • Pokud má místní zařízení kombinaci svazků Metro s některými upřednostňovanými a některými neupřednostňovanými, je nejlepší zkontrolovat každého hostitele nakonfigurovaného jako Metro_Optimized_Local a ujistit se, že všechny přidružené svazky Metro jsou nakonfigurované jako upřednostňované na místním zařízení, nebo upravit přístup hostitele k Metro_Optimized_Remote.


Zástupné řešení

Vzhledem k tomu, že se tento problém týká pouze systému PowerStoreOS 3.6.1.0 s hostiteli nakonfigurovanými jako společně umístění s oběma systémy, doporučujeme provést následující zástupné řešení:

  • Tento postup lze provést bez přerušení.
  • V preferovaném zařízení PowerStore nakonfigurujte přístup hostitele k: Hostitel je umístěn společně s tímto systémem.
  • V neupřednostňovaném zařízení PowerStore nakonfigurujte přístup hostitele k: Hostitel se nachází společně se vzdáleným systémem.
  • Příklad konfigurace na upřednostňovaném zařízení.
    Příklad konfigurace na preferovaném zařízení

 

V případě potřeby se obraťte na technickou podporu společnosti Dell , která vám poskytne další pomoc. 

Additional Information

Další informace

K tomuto problému může dojít také během upgradů bez rušení s hostiteli ESXi nakonfigurovanými jako Metro_Optimize_Local na neupřednostňovaných verzích.

Pokud zákazník provádí NDU z verze 3.6.1.0, doporučujeme pozastavit svazek Metro, dokončit NDU a poté znovu povolit Metro

Konektivitu hostitele lze zobrazit v uživatelském rozhraní nástroje PowerStore Manager v části Informace > o >výpočetním hostiteli HOSTITELÉ A SKUPINY HOSTITELŮ.
Pro snadnější ověření přidejte sloupec Připojení hostitele do výchozího zobrazení:

 Uživatelské rozhraní nástroje PowerStore Manager
 

Affected Products

PowerStore
Article Properties
Article Number: 000223948
Article Type: Solution
Last Modified: 18 Jun 2025
Version:  8
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.