Dell Unity : Le bilan de santé préalable à la mise à niveau échoue avec l’erreur suivante : Check_connectemc_sender_1

Summary: Le bilan de santé préalable à la mise à niveau (Pre-Upgrade Health Check, PUHC) échoue avec l’erreur suivante : ERROR_CODE=plate-forme ::check_connectemc_sender_1|Erreur|IMPOSSIBLE DE PROCÉDER À LA MISE À NIVEAU (corrigible par Dell) ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Le bilan de santé préalable à la mise à niveau (Pre-Upgrade Health Check, PUHC) échoue avec l’erreur suivante :
ERROR_CODE=platform::check_connectemc_sender_1|Error|
UPGRADE CANNOT PROCEED.
check_connectemc_sender_1
errors :0x1000300- Operation failed. Error code: 0x1000300 The requested object could not be found on the system. Recheck the command name. 0x6400bee - Failed to perform the operation because connect home has not been configured

Cause

Remarque : À partir de Unity OE 5.3, ConnectHome Notifications de connectivité à l’aide de <serialNumber>@dell.com ne sont plus la valeur par défaut.


Lors de la configuration de la connectivité ConnectHome, incluez une adresse e-mail du nom de domaine du système ou une adresse e-mail applicable qui réussit l’authentification à partir de votre serveur SMTP.

Pour activer SupportAssist dans la version 5.3 et les versions ultérieures, ConnectEMC doit disposer d’une adresse e-mail de l’expéditeur.

Resolution

Il existe deux options pour résoudre ce problème.

  1. Ignorez le PUHC et effectuez la mise à niveau. Ajoutez l’adresse e-mail de l’expéditeur ultérieurement.
  2. Ajoutez l’adresse e-mail de l’expéditeur maintenant, puis effectuez la mise à niveau.


Option 1 : Ignorez le PUHC et effectuez la mise à niveau

  1. Exécutez la commande ci-dessous :
svc_skip_puhc
  1. Exécutez la commande ci-dessous pour ignorer l’erreur :
+58

50: flr::check_for_disk_transitions
51: flr::check_for_faulted_disks
52: flr::check_for_no_pulled_disks
53: flr::check_for_snaps_in_an_active_state
54: flr::check_movesession_exists
55: slic::check_for_slic_committed
56: platform::check_centralized_esrs_version
57: platform::check_unsupported_proxy
58: platform::check_connectemc_sender
  1. Une fois le check_connectemc_sender est ignorée, démarrez la mise à niveau à partir de Unisphere.
  2. Ajoutez l’adresse e-mail de l’expéditeur pour ConnectEMC. (Voir ci-dessous)


Option 2 : Ajoutez l’adresse e-mail de, puis effectuez la mise à niveau

Il existe trois options pour ajouter l’adresse e-mail de l’expéditeur :

  1. Unisphere
  2. svc_connectemc Commandes
  3. Uemcli Commandes

Unisphere :

SMTP

svc_connectemc :

  1. Exécutez la commande ci-dessous pour afficher ConnectEMC Statut:
svc_connectemc -s

ConnectEMC: NOTRUNNING DISABLE
  1. Tester la capacité de ConnectEMC Pour envoyer un message au support avec la commande ci-dessous :
spa:/cores/service/user# svc_connectemc -t

ERROR [spa]: Email (ConnectEMC) not configured
  1. Exécutez la commande ci-dessous pour afficher ConnectEMC Détails de la configuration :
svc_connectemc -g

INFO [spa]: SMTP Host: smtp.server.com
INFO [spa]: SENDER EMAIL: DP-Unity01@dell.com
INFO [spa]: EMC Destination Email: emailalert@emc.com
  1. Exécutez la commande ci-dessous pour définir l’adresse e-mail ConnectEMC Utilise pour envoyer des alertes :
05:57:12 root@CKM002XXXXX929 spa:/cores/service/user# svc_connectemc -m DP-Unity01@dell.com

INFO [spa]: Verifying peer connectivity ...
ERROR [spa]: Email (ConnectEMC) not configured. Please enable connetEMC first.
  1. Exécutez la commande ci-dessous pour activer ConnectEMC:
05:58:30 root@CKM002XXXXX929 spa:/cores/service/user# svc_connectemc --enable 10.1XX.1XX.1X1 --sendermail DP-Unity01@dell.com

INFO [spa]: Verifying peer connectivity ...
INFO [spa]: Enabling ConnectEMC
INFO [spa]: Verifying peer connectivity ...
INFO [spa]: copying connectEMC config to peer
INFO [spa]: Persisting SMTP server configuration
INFO [spa]: Persisting sender email address configuration
INFO [spa]: ConnectEMC has been enabled successfully.
  1. Après activation ConnectEMC, testez la connexion
    svc_connectemc -t
    INFO [spa]: Test Dialhome request 

UEMCLI :

  1. Exécutez la commande ci-dessous pour répertorier la configuration actuelle :
uemcli /sys/support/connecthome show -detail

1:  Enabled       = yes
   SMTP server     = 10.1XX.1XX.1X1
   E-mail from address = (none)@emc.com 
   E-mail to address  = emailalert@emc.com
Avant l’activation ConnectEMC, si vous vérifiez la commande test, elle échoue avec une erreur : 
Operation failed. Error code: 0x1000300
The requested object could not be found on the system. Recheck the command name. (Error Code:0x1000300)
  1. Exécutez la commande ci-dessous pour activer la commande ConnectEMC
uemcli -d 10.0.0.1 -u local/joe -p Password /sys/support/connecthome set –enable yes –smtpServer 10.10.22.22 -emailFromAddr DP-Unity01@dell.com
Après activation ConnectEMC, si vous le testez, il passe avec succès :
09:05:02 root@CKM002XXXXX929 spb:/cores/service/user# uemcli -u admin -securepassword /sys/support/connecthome test
Password:
Storage system address: 127.0.0.1
Storage system port: 443
HTTPS connection

Remote certificate:
Issuer:   CN=DP-UNITY01
Subject:  CN=DP-UNITY01
Valid from: 2020:06:14:07:13:27
Valid to:  2023:06:14:07:13:27
Serial:   00a382cb17422be9fd
Id:     2957123456
Would you like to:
 [1] Accept the certificate for this session
 [2] Reject the certificate
Please input your selection (The default selection is [1]):
Operation completed successfully.
  1. Répertoriez les détails actuels après la modification de la configuration :
uemcli /sys/support/connecthome show -detail

Please input your selection (The default selection is [1]):
1:  Enabled       = yes
   SMTP server     = 10.1XX.1XX.1X1
   E-mail from address = DP-Unity01@dell.com
   E-mail to address  = emailalert@emc.com

Additional Information

Affected Products

Dell EMC Unity Family
Article Properties
Article Number: 000224165
Article Type: Solution
Last Modified: 18 Dec 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.