PowerFlex 网关 SSL 证书每 90 天到期一次,导致 CSI 驱动程序失败。
Summary: PowerFlex 网关安全套接字层 (SSL) 证书每 90 天到期一次。这会影响使用此证书的 Container Storage Interface (CSI) Driver for PowerFlex 部署。
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Symptoms
当包含证书的机密过期时,它会导致驱动程序的部署失败。PowerFlex 驱动程序节点 Pod 和控制器 Pod 处于“CrashLoopBackOff”状态,因为它们无法验证证书。用户无法执行资源调配。
Cause
此命令获取 PowerFlex 网关证书。但是,PowerFlex 网关证书每 90 天到期一次。
openssl s_client -showcerts -connect <Gateway IP:Port> </dev/null 2>/dev/null | openssl x509 -outform PEM > ca_cert_0.pem
Resolution
解决方法:
如果用户由于证书过期或吊销而在访问驱动程序时遇到问题,他们可以按照以下步骤解决问题:
1.使用以下命令更新密码证书:
这些步骤有助于确保驱动程序可以使用更新的证书与服务器建立安全连接。
如果密码具有 PowerFlex 网关 SSL 证书,并且用户希望将其替换为平台根颁发机构证书 (CA):
1。使用以下命令获取证书(平台根 CA):
3.然后通过删除驱动程序 Pod 重新启动驱动程序。所有 Pod 都应处于运行状态,没有任何 Pod 处于“CrashLoopBackOff”状态。
分辨率:
此问题预计将在 PowerFlex 4.6.x 中得到解决。
如果用户由于证书过期或吊销而在访问驱动程序时遇到问题,他们可以按照以下步骤解决问题:
1.使用以下命令更新密码证书:
kubectl create secret generic vxflexos-certs-0 -n vxflexos --from-file=cert-0=ca_cert_0.pem -o yaml --dry-run | kubectl replace -f -2.重新启动驱动程序,以确保使用最新更新的密码来验证服务器返回的 SSL 证书。
这些步骤有助于确保驱动程序可以使用更新的证书与服务器建立安全连接。
如果密码具有 PowerFlex 网关 SSL 证书,并且用户希望将其替换为平台根颁发机构证书 (CA):
1。使用以下命令获取证书(平台根 CA):
kubectl get secret -n powerflex ca-key-secret -o json -o=jsonpath="{.data.tls\.crt}" | base64 -d > ./pfmp_platform_ca.crt 2.替换密码。
3.然后通过删除驱动程序 Pod 重新启动驱动程序。所有 Pod 都应处于运行状态,没有任何 Pod 处于“CrashLoopBackOff”状态。
分辨率:
此问题预计将在 PowerFlex 4.6.x 中得到解决。
Affected Products
PowerFlex appliance R640Products
PowerFlex rack, VxFlex Ready Nodes, PowerFlex custom node, PowerFlex appliance R650, PowerFlex appliance R6525, PowerFlex appliance R660, PowerFlex appliance R6625, Powerflex appliance R750, PowerFlex appliance R760, PowerFlex appliance R7625
, PowerFlex appliance R740XD, PowerFlex appliance R7525, PowerFlex appliance R840
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Article Properties
Article Number: 000226935
Article Type: Solution
Last Modified: 08 Nov 2025
Version: 4
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